iframes, input images/buttons are not displayed/rendered/visible/are missing 20030723 regression

VERIFIED FIXED

Status

()

Core
Layout
--
major
VERIFIED FIXED
14 years ago
14 years ago

People

(Reporter: Steffen Wilberg, Unassigned)

Tracking

({regression})

Trunk
x86
All
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030723 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030723 Mozilla Firebird/0.6

When you reply to a forum post on MozillaZine, it used to display a review of
the previous posts in that topic in reverse order, called topic review. With the
latest build, only a grey box is displayed.

Reproducible: Always

Steps to Reproduce:
1. Reply to any topic on a MozillaZine forum.
2. Look at topic review.

Actual Results:  
Grey Box.

Expected Results:  
A review of the previous posts in reverse order.

This was first mentioned on http://forums.mozillazine.org/viewtopic.php?p=124552
(Reporter)

Comment 1

14 years ago
Seems to be a problem with iframes. It seems to ignore them all together.
This also happens on
http://bugzilla.mozilla.org/enter_bug.cgi?product=Firebird&format=guided
The most-frequently-reported-bugs list is not displayed. The space where it used
to be is just plain white.
(Reporter)

Comment 2

14 years ago
Mozilla is affected as well.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030723
Component: General → GFX
Product: Firebird → Browser
Summary: MozillaZine forum reply: topic review displays a grey box → iframes are not displayed on MozillaZine topic review and bugzilla
Version: unspecified → Trunk

Comment 3

14 years ago
I see this as well on Linux with my Mozilla trunk build today.  Iframes seem to
be ignored.  Marking as NEW, setting OS to all, and severity to major.
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
(Reporter)

Updated

14 years ago
Component: GFX → Layout: HTML Frames

Comment 4

14 years ago
Please assign the bug to the correct component owner when changing component.
Assignee: blakeross → frame
QA Contact: asa → madhur
(Reporter)

Updated

14 years ago
Keywords: regression
(Reporter)

Comment 5

14 years ago
Mentioned by Galapagos:
Another page that shows this bug is http://www.umich.edu/~ktonez/kopindex.htm
since it has 2 iframes with scrollers at the side (1 on the left and 1 on the
right) and neither are displayed at all.

Comment 6

14 years ago
Narrowing down the timeline:

WFM 2003072204 PC/WinXP
Broken 2003072304 PC/WinXP

Nominating as a 1.5b blocker.
Flags: blocking1.5b?
This is a regression from bug 79315
I already noticed this and backed out the part of the checkin that caused the
problem.

Fix checked in to trunk, 2003-07-23 15:46 -0700.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
*** Bug 213615 has been marked as a duplicate of this bug. ***
*** Bug 213608 has been marked as a duplicate of this bug. ***

Comment 11

14 years ago
*** Bug 213665 has been marked as a duplicate of this bug. ***

Comment 12

14 years ago
*** Bug 213695 has been marked as a duplicate of this bug. ***

Comment 13

14 years ago
Changing the summary of this bug to maybe help stem the number of duplicates
being opened.

Verified this fix in 2003072404 build.
Status: RESOLVED → VERIFIED
Component: Layout: HTML Frames → Layout
Summary: iframes are not displayed on MozillaZine topic review and bugzilla → inframes, input images/buttons are not displayed/rendered/visible/are missing 20030723 regression

Comment 14

14 years ago
Fixing my own stupid spelling....
Summary: inframes, input images/buttons are not displayed/rendered/visible/are missing 20030723 regression → iframes, input images/buttons are not displayed/rendered/visible/are missing 20030723 regression

Comment 15

14 years ago
*** Bug 213710 has been marked as a duplicate of this bug. ***

Comment 16

14 years ago
I guess the "blocking 1.5b ?" can come off, right?
(Reporter)

Comment 17

14 years ago
sure.
Flags: blocking1.5b?
Created attachment 128804 [details] [diff] [review]
better fix

This fixes the real problem and removes the workaround.  The problem was that
my change to RelativePositionFrames didn't apply to leaf frames.  I needed to
move the code.	I also cleaned up a few things there and fixed a warning
elsewhere.
Attachment #128804 - Flags: superreview?(roc+moz)
Attachment #128804 - Flags: review?(roc+moz)
Blocks: 214077
If the root span has a view, aren't you failing to sync that view?
The root span has no frame, so it can't have a view.
aha! I thought I must have been missing something :-)
Comment on attachment 128804 [details] [diff] [review]
better fix

Just add a comment explaining that the root span never has a frame, so no view,
if you please. Looks great!!
Attachment #128804 - Flags: superreview?(roc+moz)
Attachment #128804 - Flags: superreview+
Attachment #128804 - Flags: review?(roc+moz)
Attachment #128804 - Flags: review+
Comment on attachment 128804 [details] [diff] [review]
better fix

Checked in, 2003-07-31 15:03 -0700.
You need to log in before you can comment on or make changes to this bug.