If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

melaleuca.com - online shopping OK with Netscape 6, gives browser warning to Mozilla/Netscape 7

RESOLVED FIXED in Future

Status

Tech Evangelism Graveyard
English US
P4
minor
RESOLVED FIXED
14 years ago
3 years ago

People

(Reporter: Bill Mason, Assigned: Bill Mason)

Tracking

unspecified
Future
x86
Windows XP

Details

(URL)

(Assignee)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030721 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030721 Mozilla Firebird/0.6

When accessing this site, Mozilla gets rerouted to a browser upgrade warning
page (http://www.melaleuca.com/private/Classic_index.cfm) that suggests using
Netscape 6.2 or higher.

Spoofing the UA to be a Netscape 6/7 browser allows entry, so presumably they
have a bad browser detect script.  The warning page does have a link to get
directly into the online store, so that provides a simple workaround.

I wrote the webmaster to explain the issue and suggesting
http://devedge.netscape.com/viewsource/2002/browser-detection/ as a resource
that could help them.

Reproducible: Always

Steps to Reproduce:
1. Visit http://www.melaleuca.com/private/home_index.cfm
Actual Results:  
Browser was rerouted to http://www.melaleuca.com/private/Classic_index.cfm and
user is advised to "upgrade" to Netscape 6.2+

Expected Results:  
Browser should be allowed into the site directly.

Contact is webmaster@melaleuca.com
(Assignee)

Comment 1

14 years ago
Setting priority.
Severity: normal → minor
Priority: -- → P4
(Assignee)

Comment 2

14 years ago
Resent a letter to the site since the first one went unacknowledged.
Assignee: english-us → bugzilla
(Assignee)

Comment 3

14 years ago
Correction to previous:

The site allows Netscape 6 to enter without a redirect.  Netscape 7 (and
Mozilla) get redirected to a page that suggests upgrading to Netscape 6.2.

I received a form reply that said in essence 'we don't support Netscape yet, it
doesn't support certain standards, we recommend IE'.

I have replied to point out:

1) The site already supports Netscape 6 and the problem is that Netscape
7/Mozilla users are being told to downgrade to Netscape 6.

2) Mozilla is more standards compliant than IE and asking specifically what
technology they are using that IE supports and we don't that they feel is
critical (considering I have completed transactions on the site using Mozilla
and having no problems at all).
Status: NEW → ASSIGNED
Summary: melaleuca.com - online shopping OK with Netscape 6.2+, gives browser warning to Mozilla → melaleuca.com - online shopping OK with Netscape 6, gives browser warning to Mozilla/Netscape 7
Target Milestone: --- → Aug
(Assignee)

Comment 4

14 years ago
I got a partially useful reply.

IE users when shopping get a different shopping cart experience than
Mozilla/Netscape users.  What technology underlies that difference I don't know,
but they are still working on creating an equal experience for Moz/Netscape.

My main issue, the bad browser detect, went ignored again in the latest reply.

Going to Future the bug since they are working on what would eventually fix the
problem, and I can get no direct answer at present regarding the busted browser
detect.
Target Milestone: Aug → Future
It seems that this site has been fixed - the page
http://www.melaleuca.com/private/home_index.cfm works for me in Firefox 20040405
on Linux.

However, the page http://www.melaleuca.com/wc/index.cfm?CountryIden=1 (click on
"United States" at home_index.cfm) has this text at the bottom:

"For optimal viewing of Melaleuca.com we recommend the following:
PC : Windows running Internet Explorer 5.5 or higher
Macintosh : Internet Explorer 5.2 or higher"

but nonetheless it seems to work ok (note that I didn't try doing actual
shopping at this site).
(Assignee)

Comment 6

13 years ago
Fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.