Attachment pane does not show vertical scroll bar in classic theme, shows it in modern

RESOLVED DUPLICATE of bug 122180

Status

SeaMonkey
MailNews: Message Display
RESOLVED DUPLICATE of bug 122180
15 years ago
13 years ago

People

(Reporter: kochhar, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

I received a message with 3 attachments, but the attachment pane only shows 2 of
them and doesn't show a vertical scrollbar and so there's no way to know that
there's a 3rd attachment except by doing File->Attachments (in classic theme);
in the modern theme it shows the vertical scrollbar.

Reproducible: Always

Steps to Reproduce:

Actual Results:  
Not sure how to reproduce it.  I can send someone the email I received, but note
that when I forwarded the email to someone else, my copy did show a scrollbar
for the 3 attachments in the copy.  Note that the email I received has only a
Subject, Date and From lines, whereas when I forward it, it gets one more line
(the To line, even with BCC only to myself, I see To: undisclosed-recipients)
--- so the 4 lines seem to make the attachment pane size differently and it puts
the vertical scrollbar.

I then switch to the modern them and restart mozilla and the attachment pane for
the original message shows the same 2 attachments in the tiny window, but does
have a scrollbar to get to the 3rd (sceenshots to be attached shortly).  Coming
back to the classic theme still shows the problem.



This bug also demonstrates that the need for the sizing of the message header
area to be adjustable via dragging the separator from the body, though there
seem to be several bugs about the size of the pane already.  Also, it might be
related to bug  196068, though I'm not sure from the description if it's the
same problem.
(Reporter)

Comment 1

15 years ago
Created attachment 128428 [details]
Image showing the bug in classic theme and working in modern

The attached image has 5 images (from top to bottom):
(1) showing the bug --- classic theme, note the 2 attachments shown, no scroll
bar
(2) File->Attachments showing that there are 3 attachments
(3) same message in modern theme --- note 2 attachments shown, but scroll bar
visible
(4) scrolling down in the attachment pane, 3rd attachment shows up (correct)
(5) same message forwarded BCC to myself, classic theme, but now the 3
attachments show up (3rd one partially visible), but scrollbar shows up

Comment 2

15 years ago
Note that the mention of the "Classic" theme in the summary of the dupe is a bit 
of a red herring, I think this symptom occurs in most if not all themes.

*** This bug has been marked as a duplicate of 122180 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.