Dragging Tab Down Locks up X on Linux

RESOLVED INVALID

Status

()

Firefox
General
--
critical
RESOLVED INVALID
15 years ago
15 years ago

People

(Reporter: Scot Hale, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030715 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030715 Mozilla Firebird/0.6

When I have two or more tabs open and I down click on the center of a tab (the
actual tab and not the content window) hold my the button down, and move it to
the content window, before I let go of the button (upClick) the browser will
freeze.  This also freezes the rest of X windows.  So I have to go to a terminal
(ctrl-alt-f1) and kill Firebird.  After I kill it and return to X everything is
okay, and the browser is gone.

Reproducible: Always

Steps to Reproduce:
1. open two or more tabs
2. downclick on the center of on (it doesn't matter if it is active or not)
3. hold the mouse down and drag it to the content window
4. As soon as it enters the content window you should see it lock up.

Actual Results:  
Everything Locks up.  You can still move the mouse around though, and instead of
a pointer it is a right angle pointing to the upper left.   But you can click on
anything.

Expected Results:  
I don't think it should lock up everything.

RedHat 9 kernel 2.4.20-18.9 using gnome desktop.

Comment 1

15 years ago
You must be using TBE. There is no ability to drag tabs in a default install. I
installed TBE, did what you describe and managed to bog down the browser and
ultimately crash it. It did not however take the rest of X down with it or lock
it up (thank goodness).
(Reporter)

Comment 2

15 years ago
You are right, I am using the Tabbed Browser Extension.  Does this mean I should
consider it to be unstable and use at my own risk?

I noticed it is just a platform thing.  Trying the same thing on windows
actually loads the page of the tab you dragged, no problems.

Comment 3

15 years ago
Sometimes it loads the dragged URL and sometimes it bogs down or worse. So yes,
consider it unstable and use at own risk (or just don't drag tabs). You may want
to inform Piro about this though.

Marking INVALID since this is not a bug with the browser itself.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.