If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

prefs to customize image placeholder and view image option in context menu

RESOLVED DUPLICATE of bug 12770

Status

()

Core
Layout: Images
--
enhancement
RESOLVED DUPLICATE of bug 12770
14 years ago
14 years ago

People

(Reporter: Eugene Janusov, Assigned: Jim Dunn)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030718
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030718

First of all, sorry for my bad English. :-)

1. I think it will be a good idea to add a customizable option like "Show image
download placeholders" in the Internet Explorer. It means, if this options is
set "false", and "Do not load any images" is on (or if some images aren't loaded
by image permission settings), then the browser will show alternative text for
this image instead of the actual picture. Else, when this option is set to true,
the browser will draw a rectangle with this image sizes and beveled border, like
in the IE.
Correct me if I'm wrong or miss something, I know about the hidden preference
"browser.display.show_image_placeholders", but... does it really work? In any
case, when I set it "true" or "false" and an image (with width and height
attributes) isn't loaded, Mozilla makes the image place blank. It keeps image
sizes, but without a frame. It isn't very comfortable, in my opinion.

2. "View image" in the image context menu is a very useable feature when you
surf through internet with "Accept all images" option. However, many people (at
least in Russia and other exUSSR countries) pay for traffic and don't load any
images at all. But if they come to an interesting page they may want to load
some or all images at this page. In this case it wiil be very useful to have
image context menu option like "Show Picture" in the IE to load one particular
image from the same page. Also there is a very useful button "Show Images" in
the Netscape Communicator 4 for loading all images for the current page and
image mode switch button at the Opera 7 address bar, which allows to change
image mode directly from main browser window.

Reproducible: Always

Steps to Reproduce:

Comment 1

14 years ago
Request 1 (being able to toggle show/hide image placeholders) is a dup of bug 12770.

Request 2 (show image option) is a dup of bug 47475.

Dup'ing to 12770 since that one came first.  Please limit bug reports to one
issue per report.

*** This bug has been marked as a duplicate of 12770 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
>"Do not load any images" is on (or if some images aren't loaded
>by image permission settings), then the browser will show alternative text 

um...
If "Do not load any images" is on, we currently do show the alternative text
(you need to restart mozilla for that to work)
If you blocked an image, we do (intentionally) not show any alt text, because
the thought is that you don't want to see it at all.

> "browser.display.show_image_placeholders", but... does it really work?

yes. it does exactly what it says - doesn't display image placeholders (the
loading/broken images)

You need to log in before you can comment on or make changes to this bug.