[AxPlugin] ActiveX plugin crashes on first load and wants mozz.dll

RESOLVED WONTFIX

Status

Core Graveyard
Embedding: ActiveX Wrapper
--
critical
RESOLVED WONTFIX
15 years ago
6 years ago

People

(Reporter: Aaron Kaluszka, Assigned: Adam Lock)

Tracking

({crash, top100})

Trunk
x86
Windows XP
crash, top100

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
When the ActiveX plugin is installed and Firebird is restarted, Firebird
complains it can't find mozz.dll.  When an ActiveX control is first loaded, the
plugin crashes, but works for the rest of the session when the "do not tell me
this again" checkbox is checked.  Then, on exit of Firebird, the whole
application crashes.  I've tried several builds over the past few weeks, but
always used the plugin install at http://www.iol.ie/~locka/mozilla/plugin.htm
(Assignee)

Comment 1

15 years ago
Which version of Firebird is this with?
Summary: ActiveX plugin crashes on first load and wants mozz.dll → [AxPlugin] ActiveX plugin crashes on first load and wants mozz.dll
(Reporter)

Comment 2

15 years ago
Every version I've tried since about the beginning of the month.  The latest
being 20030723.  I'll try a completely fresh build just to make sure it's not
that.  It may be that bug 210580 is interfering somehow; I'll have to look into
it a bit more.
(Assignee)

Comment 3

15 years ago
Then I'll mark this WONTFIX. The plugin is designed for the 1.4 derived versions
of Moz & Firebird and nothing else (the site even says as much). Later versions
of Firebird will require their own versions of the plugin since it has
dependencies on xpcom.dll and elsewhere which make it likely to crash or not
load properly if loaded against a version it was not built for.

It would be nice to build the plugin in Firebird nightlies but it remains to be
seen if that would be acceptable. In the meantime I'll just be tracking point
releases.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
Component: Embedding: ActiveX Wrapper → Embedding: ActiveX Wrapper
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.