broadway.com uses IE-specific javascript

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
English US
RESOLVED WORKSFORME
15 years ago
3 years ago

People

(Reporter: ted, Unassigned)

Tracking

unspecified

Details

(URL)

Steps to reproduce:
1) Go to http://www.broadway.com
2) Click "Broadway" on the left side, under "Buy Tickets"
3) Click on a show name
4) Click on "Buy Tickets"
5) Click a showtime
6) Click "Proceed"
7) Fill in a lot of information (doesn't matter what you put there, it won't work)
8) Click "Proceed"

Expected Results:
Next page loads with more info on buying tickets

Actual Results:
Nothing happens.


It looks like they're using document.formname instead of document.forms['formname'].

--

Here is the mail I sent via their feedback form:

Hi,

I was attempting to use your site to buy tickets, but the javascript code on
your site does not support my browser, Mozilla.  It seems that on the page
http://www.broadway.com/step3.asp, in the function "validate", you refer to the
form by document.formname, which is not valid javascript outside of Internet
Explorer.  The correct way to access the form is by document.forms['formname'],
which will work in all browsers.  There may be other errors as well, but that is
the first one I noticed.

Unfortunately I won't be able to order tickets from your site unless this is
fixed, since I don't ever use Internet Explorer.  You might also consider that
you're probably blocking out people who use Apple computers as well, which you
probably don't want to do.

-Ted

Comment 1

15 years ago
Thanks Ted. Let us know what they say in reply. If they need help, they can
contact me directly or comment this bug.
Status: NEW → ASSIGNED
Target Milestone: --- → Aug

Comment 2

14 years ago
[bug248549notfixed]
Looks like they've redesigned and it fixes this, since I just ordered tickets
using Firefox.  Marking WFM.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.