Crash when deleting table cell

VERIFIED FIXED in M13

Status

()

Core
Editor
P3
critical
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: Charles Manske, Assigned: Charles Manske)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

18 years ago
Create any size table.
Place caret in a cell.
Use menu: Table | Delete | Cell.
We crash.
Mea culpa - inadequate testing for a table editing code change.
We need to obtain the selection before deleting cell (easy fix).
This should be fixed for M12 as we are trying to get basic table editing tested
in this release.
(Assignee)

Updated

18 years ago
Target Milestone: M12

Updated

18 years ago
Assignee: beppe → karnaze

Comment 1

18 years ago
reassigning to Karnaze for review, Chris reassign as appropriate.
(Assignee)

Updated

18 years ago
Assignee: karnaze → cmanske
(Assignee)

Comment 2

18 years ago
It's my bug! It is in editor table editing code - fix is ready.

Comment 3

18 years ago
great! I thought it may be a karnaze thing -- sorry!

Updated

18 years ago
Severity: normal → critical

Updated

18 years ago
Whiteboard: [PDT-]

Comment 4

18 years ago
Cell manipulation is not dogfood.  Putting on the PDT- radar.

Updated

18 years ago
Target Milestone: M12 → M13

Comment 5

18 years ago
moving to m13 since it isn't considered dogfood
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 6

18 years ago
Fix is done. Waiting for M13 checkins.
(Assignee)

Comment 7

18 years ago
*** Bug 22231 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Summary: [dogfood]Crash when deleting table cell → Crash when deleting table cell
Whiteboard: [PDT-]

Comment 8

18 years ago
updating summary fields, removing PDT- & [dogfood]
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 9

18 years ago
Checked in 1/13

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 10

18 years ago
verified in 1/18 build.
You need to log in before you can comment on or make changes to this bug.