In textareas, non-breaking spaces (0xa0) are involuntarily changed to breaking spaces (0x20)

RESOLVED DUPLICATE of bug 195946

Status

()

Core
HTML: Form Submission
--
major
RESOLVED DUPLICATE of bug 195946
15 years ago
5 years ago

People

(Reporter: Timwi, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624 WebWasher 3.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624 WebWasher 3.2

Recently discovered on Wikipedia, http://www.wikipedia.org/

If you receive a form from the server which contains a textarea, which in turn
contains 0xa0 characters (ISO-8859-1 non-breaking spaces), and the submit the
form without any changes, Mozilla sends 0x20 (spaces).

This goes against all user expectation and is therefore a major bug.

Reproducible: Always

Steps to Reproduce:

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 195946 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.