missing entries for subset, subsetneq, wedge, vee, cap and cup in mathfont.properties

RESOLVED FIXED in mozilla1.9.3a5

Status

()

RESOLVED FIXED
16 years ago
9 years ago

People

(Reporter: gemi, Assigned: fredw)

Tracking

Trunk
mozilla1.9.3a5
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 6 obsolete attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686) Gecko/20030701 Galeon/1.3.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030724

There is not entry for ⊂ in mathfont.properties
I included following line

operator.\u2282.infix = lspace:thickmathspace rspace:thickmathspace

I looked into MathML spec, and it seems that it doesn't define it either.
This is strange, because after all ⊂ is an operator like ∈

Reproducible: Always

Steps to Reproduce:
Load the page http://www.mozilla.org/projects/mathml/demo/basics.xhtml

Comment 1

15 years ago
> operator.\u2282.infix = lspace:thickmathspace rspace:thickmathspace

Default metadata included to mathfont.properties (on 1.6 trunk).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

15 years ago
The following are still missing:
operator.\u228A.infix = lspace:thickmathspace rspace:thickmathspace # ⊊

operator.\u2228.infix = lspace:thickmathspace rspace:thickmathspace # ∨

operator.\u2227.infix = lspace:thickmathspace rspace:thickmathspace # ∧

operator.\u2229.infix = lspace:thickmathspace rspace:thickmathspace # ∩

operator.\u222A.infix = lspace:thickmathspace rspace:thickmathspace # ∪
 
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 3

15 years ago
Created attachment 150608 [details]
A small testpage to demonstrate the situation ...

I can aggree to that error message ...

Comment 4

15 years ago
Created attachment 150609 [details]
And how it looks like on my system ...

Comment 5

15 years ago
My System W2000 and Mozilla 2004042109

Comment 6

15 years ago
Confirming per above comments.

Keyword: testcase
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
QA Contact: ian → mathml
(Assignee)

Comment 7

9 years ago
Created attachment 406276 [details]
Testcase (XHTML document)

Entity names: http://www.w3.org/2003/entities/2007xml/mml2.xml
(Assignee)

Comment 8

9 years ago
Created attachment 406284 [details]
Testcase - inside a <math/>
(Assignee)

Comment 9

9 years ago
Created attachment 406293 [details]
Testcase - inside a <math/>
Attachment #406284 - Attachment is obsolete: true
(Assignee)

Comment 10

9 years ago
Created attachment 406299 [details] [diff] [review]
Add operators in mathfont.properties

The patch applies on top of patch from bug 519126
(Assignee)

Comment 11

9 years ago
The entity names of this bug are already in content/mathml/content/src/mathml.dtd

All MathML entities in attachment 406293 [details] render well. I guess it's not a bug if it's not the case in attachment 406276 [details], because they may not exist in XHTML (I've not checked).
(Assignee)

Updated

9 years ago
Attachment #150608 - Attachment is obsolete: true
(Assignee)

Updated

9 years ago
Attachment #150609 - Attachment is obsolete: true
(Assignee)

Updated

9 years ago
Attachment #406276 - Attachment description: Fix errors in the original testcase → Testcase (XHTML document)
(Assignee)

Comment 12

9 years ago
I can work on this, now bug 519126 is fixed. I've to check what the W3C specs says about the MathML entities used in XHTML.
Assignee: rbs → nobody
OS: Linux → All
Hardware: x86 → All
(Assignee)

Updated

9 years ago
Blocks: 534970
Summary: missing entry for &subset; (&#x02282) in mathfont.properties → missing entries for subset, subsetneq, wedge, vee, cap and cup in mathfont.properties
(Assignee)

Updated

9 years ago
Assignee: nobody → fred.wang
(Assignee)

Comment 13

9 years ago
> I've to check what the W3C specs says about the MathML entities used in XHTML.

The entities not displayed in attachment 406276 [details] are not defined in HTML4 or XHTML*, so it is not a bug. They will probably be defined in (X)HTML5 but this is a separate issue anyway.
(Assignee)

Comment 14

9 years ago
Created attachment 432222 [details] [diff] [review]
Patch
Attachment #406299 - Attachment is obsolete: true
Attachment #432222 - Flags: review?(karlt)
Comment on attachment 432222 [details] [diff] [review]
Patch

>-operator.\u2284.infix = lspace:5 rspace:5 # &nsub;
>+operator.\u2284.infix = lspace:5 rspace:5 # &nsub; &subsetneq;

subsetneq is actually U+228A (as is subne).

>+operator.\u2227.infix = lspace:4 rspace:4 # &wedge;
>+operator.\u2228.infix = lspace:4 rspace:4 # &vee;
>+operator.\u2229.infix = lspace:4 rspace:4 # &cap;
>+operator.\u222A.infix = lspace:4 rspace:4 # &cup;

r=karlt on these.
Attachment #432222 - Flags: review?(karlt) → review+
(Assignee)

Comment 16

9 years ago
Created attachment 436441 [details] [diff] [review]
Final Patch

2284 => 228A
Attachment #432222 - Attachment is obsolete: true
(Assignee)

Updated

9 years ago
Keywords: testcase → checkin-needed
nsub is U+2284.
subsetneq and subne are U+228A.

We need entries for both U+2284 and U+228A.
Keywords: checkin-needed
(Assignee)

Comment 18

9 years ago
Created attachment 436443 [details] [diff] [review]
Final Patch

oops, sorry.
Attachment #436441 - Attachment is obsolete: true
(Assignee)

Updated

9 years ago
Keywords: checkin-needed
Depends on: 533890
http://hg.mozilla.org/mozilla-central/rev/ee71110aef6d
Status: NEW → RESOLVED
Last Resolved: 15 years ago9 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a5
You need to log in before you can comment on or make changes to this bug.