Proxy: connection error causes dead tab




15 years ago
2 years ago


(Reporter: Daniel N., Unassigned)



Firefox Tracking Flags

(Not tracked)




15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b) Gecko/20030710
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b) Gecko/20030710

Entering a URL into the "Open New Location" dialog with "Open in new tab", a
dead page is spawned
if it is unable to connect to the proxy -- i.e. unlike the about:blank page, I
can't right-click on
the page, restarting the proxy and trying to reload in there doesn't work, etc.
 I can still close
the tab, though, by right-clicking on the tab.

Reproducible: Always

Steps to Reproduce:
1. Configure mozilla to use proxy
2. Make sure no proxy exists there.
3. Control-Shift-L
4. Spawn in new tab.
5. Enter url
6. Fire up proxy so mozilla can connect.
7. Try right-clicking in the body of the page for the new tab.
8. Try reloading.

Actual Results:  
Nada.  Just sits there.

Expected Results:  
Poppued up menu, reloaded, respectively.

pulling from trunk, gcc-2.95.4, stock Debian/woody toolchain, happens with
gcc-3.x as well.

Comment 1

15 years ago
Please clarify what you mean by "no proxy exists there".

You mean DNS is wrong, the IP address is wrong, the port number is wrong?

Each of these is a separate error condition.
Summary: unconfigured proxy causes dead page/tab. → Proxy: connection error causes dead page/tab.

Comment 2

15 years ago
any/all.  also if the configuration is right and the proxy is not running.
iow, mozilla is unable to connect to the proxy, whether via timeout, or via
tcp rst.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Last Resolved: 13 years ago
Resolution: --- → EXPIRED

Comment 5

13 years ago

The behavior still occurs w/ the original steps, in both new window and new tab.

This bug appears to be about "new tab".

The tab appears with a grey background in the content area, and now pulldown.

I know tabs has acted oddly (vs. new windows) for New-load errors.
Resolution: EXPIRED → ---
Summary: Proxy: connection error causes dead page/tab. → Proxy: connection error causes dead tab


12 years ago
Assignee: darin → nobody
QA Contact: benc → networking
Last Resolved: 13 years ago2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.