If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

URL crashes mozilla with X Window System error - poly request too large

RESOLVED DUPLICATE of bug 192397

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 192397
14 years ago
13 years ago

People

(Reporter: Geoff Jacobsen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686) Gecko/20030714 Galeon/1.3.5 Debian/1.3.5.20030714-3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686) Gecko/20030714 Galeon/1.3.5 Debian/1.3.5.20030714-3

 mozilla http:///www.lighthousecinema.co.nz
The program 'mozilla-bin' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadLength (poly request too large or internal Xlib length erro'.
  (Details: serial 6578 error_code 16 request_code 155 minor_code 20)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)


Reproducible: Always

Steps to Reproduce:
1. mozilla http:///www.lighthousecinema.co.nz


Actual Results:  
mozilla crashes

Expected Results:  
page showing whats on at the lighthouse :)

Note: page passes the DTD parser with no errors.

Comment 1

14 years ago
The table on the right side of the page is blank (while "view page source" shows
the text inside the table) with build ID:2003072504 (windows XP). There is also
some kind of problem with width of the table (now the table is far too wide).

IE 6.0 shows the page right(?).

Comment 2

14 years ago
Works fine for me on Linux with cvs 20030725 - though the page has HUGE
font which i have to scroll for infinity to read. Basically he is doing

<h1><font color="#993300" size="+3"
 face="Times New Roman, Times,
serif"><big><big><big><big><big><big><big><big><big><big><big><big>
<big><big><font color="#993300"><small>  Welcome to the Light                  
       
                House                                          
Cinemas</small></font></big></big></big></big></big></big></big></big>
</big></big></big></big></big></big></font>

So basically if you don't have enough memory to render the font you crash. I 
have 1gb on my box, so it works just fine, though the page is basically
useless. 

This needs to go to evangalism to contact the page author to get it fixed.

Mozilla should really have a max font size option so it doesn't just
crash. I've also commented on bug 210931 which shows that mozilla doesn't
reset gtk's error handler which is just to exit() so we never can catch
these type of allocation failures from X. No one seems to be bothered with
fixing it.

Comment 3

14 years ago
Debian uses xft-enabled builds, so what you're seeing is bug 192397 - "Font
sizes over 300pt crash mozilla built with xft and gtk2"

marking dupe

*** This bug has been marked as a duplicate of 192397 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 4

14 years ago
I have xft and gtk2 compiled mozilla. It is not crashing mine.

Comment 5

14 years ago
Works with 1.4 on Linux. Box has 256 MB memory [[SuSE 8.0 Linux]]
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.