Browser hangs when left clicking on link to download external application associated files.

VERIFIED FIXED

Status

Core Graveyard
File Handling
--
critical
VERIFIED FIXED
15 years ago
2 years ago

People

(Reporter: Jason Bassford, Assigned: Biesinger)

Tracking

({hang, regression})

Trunk
x86
Windows 2000
hang, regression

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(5 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030726
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030726

It's no longer possible to download any .tar.gz file.  When attempting to do so,
the browser will simply hang.  I can exit Mozilla but then have to kill the process.

Reproducible: Always

Steps to Reproduce:
1. Try to download the reference URL.

Actual Results:  
Browser hangs, must be exited and process killed.

Expected Results:  
Download should have started.

This seems to happen at every site, so long as the file being saved has a
.tar.gz extension.

I suspect this may be regression from bug 147679, but I'm only speculating since
I haven't tried to download such a file in a while.  (This may have started
happening earlier than 24 hours ago.)
(Reporter)

Updated

15 years ago
Keywords: hang, regression

Comment 1

15 years ago
WFM, current cvs based trunk build - linux.

Modifying URL (only one "http://" not two).

> 1. Try to download the reference URL.

How exactly?  There are at least two methods I can think of for doing that --
which one are you using?
(Reporter)

Comment 3

15 years ago
It doesn't matter.  Left click or right click and Save Link Target As.  I never
get a download prompt - Mozilla just freezes up.
Is it using 100% cpu and frozen (infinite loop of some sort) or using no CPU and
frozen (deadlock-ish)?
(Reporter)

Comment 5

15 years ago
Oddly, Task Manager shows 0% CPU.  Mozilla *does* let me close existing tabs and
open new ones - although new tabs never finish loading anything.  All screen
elements (such as the throbber and the loading animation) are frozen.

Even if I close the tab in which I tried to download the .tar.gz, Mozilla
continues to be (almost) completely unresponsive and never does anything useful.

Perhaps this doesn't count as a "hang" in the strict sense?

A comment on MozillaZine confirms the same thing happening with the 7/26 build
of Firebird.

Comment 6

15 years ago
should it depend on bug 144334 ?
(Reporter)

Comment 8

15 years ago
I would say they're related but not part of an actual dependency chain.  (Fixing
one won't help to fix the other.)

Comment 9

15 years ago
ok, I just thought the process described in bug 144334 comment 26 was very
specific to the host apache.org and the issue described here involves 2 similar
elements: MIME type and a .tar.gz file from apache.org.
Eventhough it's a regression, I thought fixing one would fix the other.
Sorry for the spam, I was just trying to link bugs in case the older one had
been forgotten. :)
hm... this works for me, with 2003072604 on windows 2000. I loaded the url from
the url field here, chose "Save", and let the file download. everything worked fine.
(Reporter)

Comment 11

15 years ago
The 7/27-04 build is still doing this.  Also, I've now downloaded the 7/26 build
of Firebird for myself and see it there too.  (Previously I'd just relayed what
somebody else had said about it.)

However, it looks like I must have mis-reported the right-click Save As
behaviour before, because it does appear to work without a problem that way. 
Only on left-clicking the link does the browser hang.
Summary: Browser hangs when downloading tar.gz files. → Browser hangs when left clicking on link to download tar.gz files.
So let me get something straight.  This is happening with firebird.  Is it
happening with SeaMonkey too?  Does it happen if you just load this bug page and
click the "URL" link?

If so, what exactly happens after you click the link?  Does a helper app dialog
come up?  Do you have preferences set for such a dialog to NOT come up for this
MIME type?  Does the problem occur in a clean profile?

Finally, if the problem occurs with a clean profile, please download regmon from
http://www.sysinternals.com/ntw2k/source/regmon.shtml and attach to this bug a
registry access log which covers the timeslot when the hang happens (and not too
much else, eg not startup, because that log is pretty verbose).

The basic problem is that I have no Windows machine and biesi can't reproduce
the bug on his windows install... we need something to work with here past "it
doesn't work".

Comment 13

15 years ago
I imagine Jason was referring to Seamonkey, as that is what he usually uses.

Using Seamonkey 2003072704 trunk on win2000, however, this WFM (left click or
right click the URL from this bug page). Could it possibly a WinXP thing?
(Reporter)

Comment 14

15 years ago
> Is it happening with SeaMonkey too?

Yes.  I only use SeaMonkey.  (Although I do have Firebird installed so I can
refer to it every once in a while.)

> Does it happen if you just load this bug page and click the "URL" link?

Yes.  Or I can copy/paste the URL directly into the location bar to have it
happen.  But it doesn't matter *what* the URL is so long as it points to a
.tar.gz file.

> If so, what exactly happens after you click the link?

All network activity in the browser freezes.  All animation stops.  I can close
existing tabs, and I can open new ones - but nothing every finishes loading, nor
is there any visual progress that things are loading.  Once I've left-clicked on
a .tar.gz link, or have entered it into the location bar, there's no further
point in having the browser open.  Even after closing it, the process remains
running and must be terminated manually via the Task Manager.

>  Does a helper app dialog come up?  

No, nothing.

> Do you have preferences set for such a dialog to NOT come up for this MIME
> type?  Does the problem occur in a clean profile?

Yes.

> please download regmon ... and attach to this bug a
> registry access log which covers the timeslot

Will do.  (I have some non-Bugzilla things I need to take care of at the moment
but will get to it shortly.)

> Could it possibly a WinXP thing?

I'm thinking that's likely.  I've asked the other person who reported this as
happening at MozillaZine
(http://forums.mozillazine.org/viewtopic.php?p=128971#128971) to confirm the OS
being used.

Comment 15

15 years ago
I'm "the other person" Jason refers to.

On WinXP SP 1 using 7/26 builds of the Mozilla suite und Mozilla Firebird I'm
experiencing the exact same behaviour Jason describes.

While the Mozilla suite is an official build I downloaded from mozilla.org
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030726
FireBird I did build myself:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030726 Mozilla
Firebird/0.6.1

Comment 16

15 years ago
Created attachment 128644 [details]
Regmon capture while trying to download a .tar.gz file

Attached the requested regmon output.

Here's what I did:
- Renamed ...\Anwendungsdaten\Mozilla to ...\Anwendungsdaten\Mozilla.bak to get
a clean profile (the folder "Anwendungsdaten" is called "Application Data" on
English versions of windows, I think)
- Started Regmon
- Set Regmon's capture filter to "Mozilla*"
- Started Mozilla
- Pasted "http://www.apache.org/dist/httpd/apache_1.3.28.tar.gz" to Mozilla's
URL bar
- Started Regmon's capture
- Pressed "Return" in Mozilla's URL bar

Even though I waited for quite a few seconds (about 10 - 20), Regmon didn't
capture any more registry accesses beyond no 53.
Created attachment 128646 [details] [diff] [review]
Close some keys

I have no idea whether this is contributing to this bug, but it jumped at me
from the regmon log....  We're forgetting to close some registry keys. 
Shouldn't be an issue, apparently, but...

Patch totally untested and uncompiled due to lack of Windows build env, of
course.
Comment on attachment 128646 [details] [diff] [review]
Close some keys

On the off chance that this fixes something, is there someone who builds and
can reproduce the bug?
Attachment #128646 - Flags: superreview?(darin)
Attachment #128646 - Flags: review?(cbiesinger)
Comment on attachment 128646 [details] [diff] [review]
Close some keys

looks good... most unlikely to fix this bug, though
Attachment #128646 - Flags: review?(cbiesinger) → review+
(Reporter)

Comment 20

15 years ago
Well!

Get this.  I went to Sysinternals to download regmon (I used to have it on my
computer until I lost some data recently) and clicking on the link for it did
the same thing!

I ended up having to download it with IE.

I'm going to attach two logs here.  One for the failed download of the .tar.gz
file (mine is similar but with some differences since I use a different handler
for .zip and .tar.gz files), and one for the failed .zip download.

Is this, perhaps, something to do with downloading files that are handled by
external applications?  (Because it's obviously not JUST .tar.gz files at this
point.)
(Reporter)

Comment 21

15 years ago
Created attachment 128648 [details]
Regmon of .tar.gz download failure.
(Reporter)

Comment 22

15 years ago
Created attachment 128649 [details]
Regmon of .zip download failure.
well... that looks normal I guess...

Can you try this:
set NSPR_LOG_MODULES=HelperAppService:5
set NSPR_LOG_FILE=c:\targz.log
start mozilla.exe
(in a dos box)
and attach c:\targz.log to this bug

Comment 24

15 years ago
Might well be a problem with external applications. On my machine ".tar" and
".gz" files are handled by 7-zip. I changed the configuration of 7-zip to not
handle these any more and now going to
http://www.apache.org/dist/httpd/apache_1.3.28.tar.gz
starts the download - no hang any more.

Comment 25

15 years ago
Maybe also of interest:
I never experienced any problems with ".zip" files, which are also set to be
handled by 7-zip on my machine. So ".tar.gz" seems to be a special case - at
least for me.
(Reporter)

Comment 26

15 years ago
Created attachment 128666 [details]
HelperAppService log.

I also tried un-associating .tar.gz files from ZipMagic (my own application
handler for that filetype) and all problems went away.	Same with .zip files
(for me).  As soon as I re-associated the file extensions, I get the hang
again.

This never used to be a problem before - but I can't honestly say when,
exactly, the last time was that this worked.  I must have downloaded a file of
at least one of these two types no more that 2-3 weeks ago.
(Reporter)

Updated

15 years ago
Summary: Browser hangs when left clicking on link to download tar.gz files. → Browser hangs when left clicking on link to download external application associated files.
(Reporter)

Comment 27

15 years ago
Forgot to mention.  When trying to download regmon from Sysinternals via
right-click Save As, I kept getting "The link could not be saved.  The web page
might have been removed or had its name changed."
Jason, could you please test whether this fails in a Jul 24 evening build? Jul
25 morning build (please list exact build time for this one)?  Jul 25 evenin build?

If it fails in the Jul 24 build, don't bother to check the others, btw.
(Reporter)

Comment 29

15 years ago
Regression confirmed to have taken place between the 7/25-04 and 7/26-04 builds.
 (The bug does not exist in 7/25-04.)
um
I can actually reproduce this now

This is obviously not Win2k-specific
OS: Windows XP → Windows 2000
I meant to say "not winxp specific"

reassigning to me

Assignee: law → cbiesinger
um
for some reason, the patch in bug 214173 seems to fix this bug
I have absolutely no idea why
No longer depends on: 214172
As a note, this seems to be triggered by the existance of a
HKEY_CLASSES_ROOT\.extension key but lack of a "Content Type" string value there.
ok, bug 214173 is checked in now. Could you who are seeing this bug try
tomorrow's nightly builds and check if this bug is fixed? thanks
(Reporter)

Comment 35

15 years ago
Yes, assuming that bug 214190 is also fixed at that point... <sigh>

Updated

15 years ago
Attachment #128646 - Flags: superreview?(darin) → superreview+

Comment 36

15 years ago
I have just built a Firebird from cvs. With the resulting exe the hang is gone
but the file I downloaded from
http://www.apache.org/dist/httpd/apache_1.3.28.tar.gz
ist saved as "apache_1.3.28.tar.gz.tar".
mks99: Thanks! The bug you're still seeing is bug 144334. I'll leave this bug
open though until the patch here gets checked in (I can't do that right now)
(Reporter)

Comment 38

15 years ago
Confirming that the 7/29-04 build no longer hangs when downloading files.

As far as I'm concerned (as reporter) this bug is now fixed, so it can be marked
as such whenever the patch that's holding it up is checked in.
Fixed.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
(Reporter)

Comment 40

15 years ago
.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.