bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

can't download more than 2 files simultaneously from the same server/URL

RESOLVED DUPLICATE of bug 156743

Status

SeaMonkey
Download & File Handling
RESOLVED DUPLICATE of bug 156743
15 years ago
5 years ago

People

(Reporter: Slava Antin, Assigned: Blake Ross)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624

can't download more than 2 files simultaneously from the same server/URL.
If I'm trying to download one more file after 2 downloads are started nothing
happens, and download starts only AFTER one of two prewious are done.
No configuration option and no bug description about this can't be found.

Reproducible: Always

Steps to Reproduce:
1. Put somewhere (e.g. http://foo.com/) 3 files big enough download_me[0|1|2].mpg
2. Start download for download_me0.mpg and download_me1.mpg
3. When trying to start download of download_me2.mpg and first two are not done,
than nothing happens until one of two first downloads is over. Only after that
third one is started.

Actual Results:  
Third download is not started till two first are not over

Expected Results:  
Must be started as many as I need

Comment 1

15 years ago
about:config shows the pref network.http.max-persistent-connections-per-server
as integer with a value of 2. I assume that is the limit you are hitting, you
can try to increase it, to get more of the servers bandwith exclusively for you.
Be nice to your neighbors, don�t take it all.

Comment 2

15 years ago
Bug 156743 doesn't involve the *exact* preference, but it is essentially the
same issue.  

*** This bug has been marked as a duplicate of 156743 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey

Comment 3

14 years ago
*** Bug 274860 has been marked as a duplicate of this bug. ***

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.