Calendar doesn't install, using Mozilla 1.4, Get error code 215

RESOLVED INVALID

Status

Calendar
General
--
major
RESOLVED INVALID
15 years ago
12 years ago

People

(Reporter: Nick Taylor, Assigned: Mostafa Hosseini)

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030624

When I try to install Calendar from either one of these urls,

http://www.oeone.com/files/calendar_windows2.xpi
http://www.oeone.com/files/calendar_windows.xpi

I get the following in an Alert dialog box:

"Failed to create directory
You probably don't have appropriate permissions
(write access to mozilla/chrome directory)
If you installed Mozilla as root then you need to install calendar as root as well
Or, you can change ownership of your Mozilla directory to yourself and install
calendar
Error code: -215"

None of my folders associated with mozilla are write protected.  This message
seems more appropriate to a Unix type installation.

Reproducible: Always

Steps to Reproduce:
1.Navigate to the http://www.mozilla.org/projects/calendar/ url
2.Click either of the install links in the Windows row and the Mozilla 1.4 column.
3.

Actual Results:  
Calendar downloading proceeds normally and seems to complete.  Then when the
installation phase starts, the above mentioned error dialog appears.  The
installation fails.

Expected Results:  
It should have installed Calendar correctly or it should have told me exactly
why it could not.  I am using the classic theme in Mozilla 1.4.

When I was using Mozilla 1.0, I was able to download and install the calendar
using "install 0.8", http://www.oeone.com/files/calendar08_windows.xpi.  This
installed correctly and subsequently worked fine.  When I installed Mozilla 1.4
from a zip file, the calendar didn't show up in my navigator so I tried to
download and install the appropriate calendar version.

Comment 1

15 years ago
New contact from mikep@oeone.com to mostafah@oeone.com
Filter on string OttawaMBA to get rid of these messages. 
Sorry for the spam.
Assignee: mikep → mostafah
(Assignee)

Comment 2

14 years ago
Reporter: Please try the newest XPI available for 1.4 and close bug if problem
has been solved.
(Assignee)

Comment 3

14 years ago
*** Bug 209760 has been marked as a duplicate of this bug. ***
This bug must be outdated by now. Reporter, please close it.
no response for a few months, closing.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
The bugspam monkeys have been set free and are feeding on Calendar :: General. Be afraid for your sanity!
QA Contact: gurganbl → general
You need to log in before you can comment on or make changes to this bug.