Copy Link Location only works once

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
minor
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: Dimitry Andric, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030725 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030725 Mozilla Firebird/0.6

Whenever I load a page, I can use the "Copy Link Location" context menu item only once. After that, it doesn't work any more, nothing is put in the clipboard. Most of the time, refreshing the page or going back and forward gives me another single  'allowed' Copy Link Location, but sometimes only restarting Firebird helps.

I'm using the latest nightly from the 1.5a branch, which is located at http://ftp.mozilla.org/pub/firebird/nightly/latest-1.5a/, but the problem also occurs with the latest trunk nightly.

Reproducible: Always

Steps to Reproduce:
1. Go to web page.
2. Right-click any link, choose Copy Link Location.
3. Verify that the link is put into the clipboard, by pasting it into Notepad or some other application.
4. Right-click any link (either the same as before, or another, doesn't matter), choose Copy Link Location.
5. Verify that the link is NOT put into the clipboard this time, by trying to paste it into Notepad or some other application.

Actual Results:  
After the second "Copy Link Location" action, there was nothing in the clipboard.

Expected Results:  
After the second "Copy Link Location" action, Firebird should have copied the link location to the clipboard.

Comment 1

15 years ago
strange, WORKS FOR ME 20030726 WinXP
Severity: normal → minor

Comment 2

15 years ago
WFM using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b)
Gecko/20030727 Mozilla Firebird/0.6.1 (trunk build)
(Reporter)

Comment 3

15 years ago
Additional testing reveals that this seems to be caused by some bad interaction
with the Microsoft Remote Desktop Client (aka "Terminal Service Client",
mstsc.exe). I often have this running in the background, because I'm logged on
to multiple machines at once. The RDesktop client automatically handles
clipboard transfers from/to the machine you've logged into, and I suspect that
something weird happens here.

At them moment I'm downloading the source, to see what precisely is done when
data is copied to the Windows clipboard. I don't get any error message in
Firebird's console, so it must be something that is not very obvious.

Note that it also happens with the vanilla Mozilla 1.4 release (which I have
installed here, but almost never use).

Comment 4

15 years ago
Moving to Browser component per last comment.
Assignee: blake → general
Component: General → Browser-General
Product: Firebird → Browser
QA Contact: asa → general
Version: unspecified → Trunk
(Reporter)

Comment 5

15 years ago
Hm, I've successfully built a Mozilla CVS checkout here, but all it does at startup is hang after the splash screen shows. The last messages it shows before indefinitely spinning somewhere is:

###!!! ASSERTION: ContainsStyleSheet called on a sheet that's still loading: 'Er
ror', file d:/Home/Dim/Src/Mozilla/mozilla/content/html/style/src/nsCSSStyleShee
t.cpp, line 2001
Note: verifyreflow is disabled
Note: styleverifytree is disabled
Note: frameverifytree is disabled

I'll rebuild it a few more times with newer checkouts, but I don't think this is going to work...

Is there anywhere where I can pull a running debug build from?

Comment 6

14 years ago
Cannot reproduce on Firefox build 20040316
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7b) Gecko/20040316 Firefox/0.8.0+

Closing this bug, since the reporter noted in comment #3 that it's caused by an
external program, and there has been no further activity in over 6 months.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.