Background-image not shown (only in latest nightly-trunks)

RESOLVED FIXED

Status

()

Core
Layout
RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: u106243, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030714 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030714 Mozilla Firebird/0.6.1

Hi there!
There is a website I use to visit frequently, http://www.movie-masters.de.
It's properly displayed in FireBird, however, since the latest nightly-builds,
the background-image (two different blue lines, repeated) is not shown anymore.
It flashes up quickly, but then I get a white background.

The bug is reproducable, doesn't happen with the latest stable release 0.6, but
with the latest nightly-trunk (i.e. from July 28th).

A fix would be highly appreciated, I guess there are other websites with the
problem as well, although I could not see one.
By the way, no problems with latest Alpha of Mozilla 1.5 as well - just with
FireBird.

Thanks!
JA

Reproducible: Always

Steps to Reproduce:
1.Surf to the site.
2.See the white background.
3.Hit reload, then you see the background-image flash up shortly, then it's
white again.

Actual Results:  
White background, instead of image.

Expected Results:  
A bug-fix would be nice :).

Comment 1

14 years ago
Sev->normal
If this is confirmed, it's a bug not an enhancement.
Severity: enhancement → normal

Comment 2

14 years ago
movie-masters.de is a vanity host for http://veryshyguy.covers.de/movmas/.

The site in question is coded incorrectly.  There's multiple DOCTYPEs, <html>
tags, <head> tags, and <body> tags.  Worse, they conflict:

First <body> tag:
<BODY NOF="(MB=(ZeroMargins, 0, 0, 0, 0), L=(indexneuLayout, 1000, 404))"
STYLE="text-align: center; background-image:
url('./assets/images/mm_backg1.gif');" TOPMARGIN=0 LEFTMARGIN=0 MARGINWIDTH=0
MARGINHEIGHT=0>

Second <body> tag:
<BODY NOF="(MB=(ZeroMargins, 0, 0, 0, 0), L=(headerLayout, 950, 113))"
STYLE="text-align: center; background-image: none;" TOPMARGIN=0 LEFTMARGIN=0
MARGINWIDTH=0 MARGINHEIGHT=0>

Recommend resolving as INVALID and referring to tech evangelism.

Comment 3

14 years ago
-> Browser
-> Parser

-> regressed by 111346, maybe
Status: UNCONFIRMED → NEW
Component: General → Parser
Depends on: 111346
Ever confirmed: true
Product: Firebird → Browser
Version: unspecified → Trunk
noririty@jcom.home.ne.jp:  Why would you think that?  If you've narrowed down
the range of builds when the problem started, could you give the dates? 
Somebody who knows more than you about the codebase is likely to be able to make
a better guess based on that information.
No longer depends on: 111346
Also, a flash of the image and then its disappearance is unlikely to be a parser
problem.
Assignee: blake → other
Component: Parser → Layout
QA Contact: asa → ian
(Reporter)

Comment 6

14 years ago
@jbarros@mail.com:

Yes, there are multiple <HEAD> and <BODY>-tags inside the source, possibly
because of an include or require order, which is of course no excuse for the bad
source-code.

@David Baron:

I am no developer, so all information I can give you is only what I see with my
eyes (and what my brain makes up for itself).
First of all I wanted to apologize for any inconvenience my report may have been
responsible for, as you can see, I'm new to Bugzilla and therefore, I have a lot
to learn.
So, sorry for not expressing myself in the right way, or worse, claiming things
that are not true. :)

However, as you requested, I tracked down the build from which on the nightlies
do not show the background-image anymore.
The latest working nightly is " /pub/firebird/nightly/2003-07-22-23-1.5a ".
It does not work anymore with " /pub/firebird/nightly/2003-07-23-08-trunk ".

My guess would be, that Firebird interprets the source this way:
First it reads that the background-image-tag says "no background" and therefore,
it does not draw one.
The next background-tag says, there is a background-image an Firebird draws the
background.
And far more down the source-code reads again, " background-image: none ", so
Firebird re-draws the background to ... well, none.

This would also explain the flashing.
But as I said, this is my guess, I don't actually 'know' that stuff :(.

Thank you very much for your patience and your answers, I hope I'm not causing
too much trouble.

Best regards,
JA
(Reporter)

Comment 7

14 years ago
Hi!

Well, it seems someone from the developers saw the thread, or they changed
something else - with the recent release of the nightly-build from August 1st,
the bug is no longer present.

So I guess we can call it fixed ... or the website has changed something.
I changed it to fixed, if someone else has info, or wants to change it again, no
objections.

Thanks for your time!
Best regards,
JA
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.