Closed Bug 214215 Opened 19 years ago Closed 18 years ago

if you use firebird to submit (post) a document to a website it holds the file open

Categories

(Firefox :: General, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 183689

People

(Reporter: bill, Assigned: bugzilla)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

if you submit a page from the [windows] filesystem to a website
(http://validator.w3.org is a good example), firebird holds that file open so
that other applications won't write to it (like winVI). 

Reproducible: Always

Steps to Reproduce:
[on a windows machine--only platform tested]
1. create a junk text file (contents don't matter) and save on local drive
2. go to http://validator.w3.org
3. submit file for 'validation' 
4. try to delete the file (WITHOUT closing firebird first)

Actual Results:  
it appears that the file is being kept open after being posted (read) and is
held open until *firebird* closes (not just the tab that performed post).

Expected Results:  
firebird should release the file once it has been submited (or spool a copy in
cache when read). neither netscape nor ie exhibit this behavior.

makes editing with winVI a dog since--unlike notepad--it respects the file being
held open.
This is a duplicate of bug 183689, which in turn is a duplicate of bug 126829
(which was verified as fixed).
the 'fix' referenced for this was in april 2002. i am using the latest version
of firebird. either the bug was reintroduced or something else was fixed.
firebird still holds files open.
QA Contact: asa

*** This bug has been marked as a duplicate of 183689 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.