throbber is too big for menu bar

RESOLVED FIXED

Status

()

Firefox
Toolbars and Customization
--
trivial
RESOLVED FIXED
15 years ago
11 years ago

People

(Reporter: Greg Campbell, Assigned: David Hyatt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030726 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030726 Mozilla Firebird/0.6.1

The throbber makes the menu bar expand 5 pixels in height when the throbber is
placed there (and doesn't look very good because of it). Since this is the
default position for the throbber, the throbber should be made smaller.

Changes in bugs 212779 and/or 213896 could make this bug invalid.

Reproducible: Always

Steps to Reproduce:
1. Put throbber in menu bar. 

Actual Results:  
Menu bar height increases 5 pixels.

Expected Results:  
Menu bar should remain the same height.
(Reporter)

Comment 1

15 years ago
Created attachment 128738 [details]
throbber too big on Windows XP

Image showing behavior

Comment 2

15 years ago
Confirming on WinXP.
The throbber should be made smaller if this is going to be its default position.
IMHO it should be moved back to the navigation toolbar.

Comment 3

15 years ago
Taking QA Contact
Depends on: 212779, 213896
QA Contact: asa → bugzilla

Comment 4

15 years ago
Bug 212779 won't fix it since it's an XUL issue.
Status: UNCONFIRMED → NEW
No longer depends on: 212779
Ever confirmed: true

Comment 5

15 years ago
Dupe, see http://bugzilla.mozilla.org/show_bug.cgi?id=213896

Comment 6

15 years ago
No, not a dupe. Two different things.

Comment 7

14 years ago
I actually found this to be really confusing - it took me quite a while to work
ou why the toolbar was so high.

Having icons on the menu bar is afaik totally non-standard for all the platforms
we target. As is monitoring status on the menubar. 

I'm nominating this for 1.0 as a minor change which improves our compatibility
with UI guidelines and prevents adjusting simple configuration options from
breaking the interface.
Flags: blocking1.0?

Comment 8

14 years ago
Sorry, I've conflated the issues in bug 213896 and here. Fixing bug 213896 would
improve our UI compaibility and prevent a tiny change in the options from
messing up the entire browser UI. Sadly Hyatt seems to think it's wontfix. I
assume his decision stands even though he's no longer working on Firefox.

This bug should still be fixed for 1.0 but I'm removing my blocking nomination
since I can't be useful on windows-specific issues.

Sorry for the bugspam :(
Flags: blocking1.0?

Comment 9

14 years ago
I also find this bug very annoying. Personally I'd put the throbber back into
the navigation toolbar where it belongs, just like it is in Thunderbird, but
judging from the bug James linked to in the previous post it's not gonna happen...

For what it's worth, my personal workaround is as follows:

- Open <path to Mozilla Firefox>/chrome/classic.jar
- extract Throbber-small.gif and Throbber-small.png (full path in archive:
skin/classic/browser/)
- rename those two files to Throbber.gif and Throbber.png
- put them back into classic.jar, overwriting the existing two files

Result: a small throbber and most of all, a small menu bar.
Indeed a fairly trivial fix, but as an end-user I would have to do it for every
release, which can be a nuisance.

Comment 10

14 years ago
(In reply to comment #7)
> Having icons on the menu bar is afaik totally non-standard for all 
> the platforms we target. As is monitoring status on the menubar. 

Most people will expect the throbber to be in the menu bar, simply because IE
does it. IE's throbber also enlarges the menu bar by a couple of pixels,
similarly to FireFox (except IE's throbber seems to affect the height by 3
pixels i.s.o. 5).  
Fixed with the new icons from Arvid
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Updated

11 years ago
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.