All edit actions (Cut/Copy/Paste etc.) don't work in "View Message Source" window

RESOLVED FIXED

Status

Thunderbird
Mail Window Front End
--
major
RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: Stefan Borggraefe, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
Steps to reproduce:

1. Select a message
2. Press Ctrl+U
3. Try any of the menu items in the Edit menu of the Message Source-window

Result:
They don't work at all. The only menu item that works in this window is
File|Close Window.

Tested with Thunderbird 0.1 and WinXP.

Comment 1

14 years ago
nor does it work in Linux...

OS --> All
OS: Windows XP → All

Comment 2

14 years ago
See also this thread in Mozillazine:
http://forums.mozillazine.org/viewtopic.php?p=137933#137933

Reporting of the errors logged by JS Console.
(Assignee)

Comment 3

14 years ago
*** Bug 216302 has been marked as a duplicate of this bug. ***

Updated

14 years ago
QA Contact: asa

Comment 4

14 years ago
I've found that both Thunderbird and Firebird have a problem with their
Cut/Copy/Paste commands when:
 (I) cutting/copying from these applications to another external application, and
 (II) cutting/copying/pasting internally.
I've also found that attempting to cut/copy will erase whatever is on the
clipboard. Pasting from and external source works. The three main venues for
executing these commands have been attempted, namely (1) Edit Menu, (2)
Right-click Menu, and (3) Keyboard Shortcuts.
I am using Windows 2000, Thunderbird 0.3, and Firebird 0.7. I hope this helps. 
I've tried version 0.4 on Linux (Mandrake 9.2 using Gnome 2.4) and Copy/Paste
works if using the keyboard (Ctrl+C/V) but not using the menu. I have only
encountered this error in the "View Message Source" (have not tried elsewhere).

Hope this info helps.

Comment 6

14 years ago
The problem still exists using TB 0.5 under Windows2000. File menu operations 
do not work, but keyboard operations (i.e. Ctrl-C) works as expected.

Comment 7

14 years ago
Ctrl-A and Ctrl-C are but the only ones working. Finding text within a mail's
source still doesn't work, whether tried via clicking Edit->Find, pressing
Ctrl-F or typeahead find (which I miss most).
There's no bug addressing problems with find. Does this one cover it as well or
should I open a new one for that?
(Reporter)

Comment 8

14 years ago
Scott just fixed this by checking in the fix for bug 233976. :-)
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Depends on: 233976
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.