scope of Edit functions is inconsistent

VERIFIED INVALID

Status

()

--
minor
VERIFIED INVALID
15 years ago
13 years ago

People

(Reporter: brant, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030726 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030726 Mozilla Firebird/0.6.1

All of the functions in the Edit menu except for Find in this Page... and Find
Again apply to the place where the cursor is (or where focus is, if there's a
difference).  This is inconsistent.  All of the functions in the Edit menu
should be page-level, not focus level.

Reproducible: Always

Steps to Reproduce:
1. Put the cursor in the address bar.
2. Click Edit > Select All.
[1]

1. Put the cursor in the address bar.
2. Click Edit > Find in the page.
3. Search for something in the URL bar.
[2]
Actual Results:  
[1] The URL is selected.
[2] The page and not the URL is searched.

Expected Results:  
[1] The page is selected or
[2] The URL is searched.

Comment 1

15 years ago
Taking QA Contact as designated owner of Firebird-Menus. Sorry for bugspam.
QA Contact: asa → bugzilla

Comment 2

15 years ago
Select All(anything)

Find in This PAGE

Behavior same in IE

Comment 3

15 years ago
IE does same thing
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Comment 4

15 years ago
This is intended behaviour. That's why it says "Find in this *page*".
Markinf VERIFIED.
Status: RESOLVED → VERIFIED
OS: Windows XP → All
Hardware: PC → All

Updated

13 years ago
QA Contact: bugzilla → menus
You need to log in before you can comment on or make changes to this bug.