links in page not recognized in Mozilla

VERIFIED DUPLICATE of bug 21099

Status

()

Core
HTML: Parser
P3
normal
VERIFIED DUPLICATE of bug 21099
18 years ago
18 years ago

People

(Reporter: andreww, Assigned: rickg)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Steps to replicate:
1) launch mozilla
2)go to http://www.news.com
3) look on right hand side of page, under "one week view"

4) click on one of the bulleted items.
(for example: Enterprise Computing or  the Net)

Expected results -
Browser follows link

Actual results
Browser does not recognize that those items even are links. No underline or
change in mouse pointer

View page in Nav 4.7 to see that Nav 4.7 does in fact recognize the links.
(Reporter)

Comment 1

18 years ago
Trying to view source on this page crashes the browser ...
(Reporter)

Comment 2

18 years ago
Created attachment 3389 [details]
example of link problem
(Reporter)

Comment 3

18 years ago
View the attached file in Mozilla to see a smaller test case.

Updated

18 years ago
Assignee: troy → rickg
Component: Layout → Parser

Comment 4

18 years ago
The HTML has a SPAN nested inside of an A element.

<a
href="http://www.news.com/Newsmakers/index.html?tag=st.ne.1002.dir.Newsmakers.ne
"><span style='color: #0000FF'><font
color='#0000FF'><b>Newsmakers</b></font></span></a>

The parser is moving everything outside of the A element.

    a@0214EA24 href=/cnettv/0-122653.html?tag=st.ne.1002.dir.cnetnewstv.cn refco
unt=3<
    >
    span@0214C8D4 style=color: rgb(0,0,255);  refcount=3<
      font@020A68FC color=#0000ff refcount=3<
        b@020A62DC refcount=3<
          Text@020A6348 refcount=3<CNET News.com TV>
        >
      >
    >
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 5

18 years ago
*** This bug has been marked as a duplicate of 21099 ***

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 6

18 years ago
Agreed. Marking as verified duplicate of 21099.
You need to log in before you can comment on or make changes to this bug.