If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

nicks, actions, notices are not recoded according to charset

RESOLVED FIXED

Status

Other Applications
ChatZilla
RESOLVED FIXED
14 years ago
13 years ago

People

(Reporter: Seva Gluschenko, Assigned: Robert Ginda)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.3b) Gecko/20030218
Build Identifier: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.3b) Gecko/20030218

The ChatZilla IRC client incorrectly handles /charset command entered: while
being in /charset koi8-r mode, cyrillic channel messages are displayed normally,
cyrillic channel topic is mangled (0.8.13c) or not displayed (0.9.15) in the
channel window but is displayed normally in menu/title of ChatZilla, cyrillic
nicks aren't displayed normally.

Next, important IRC commands aren't supported: /mode, /umode (usermode), /stats,
/trace, /oper, /notice. While it's still possible to /notice somebody or get
some /stats from a server (ChatZilla claims it's unknown but passed to a
server), the /oper command requires operator's password as a parameter. When a
client supports this command, it asks for the password and hides it when typing.
Unfortunately, ChatZilla doesn't support this.

Reproducible: Always

Steps to Reproduce:
1. /charset koi8-r, connect to some Russian IRC network and try with cyrillic
nicks, cyrillic topics, etc
2. Try /notice nick message command and see the effect
3. Try /oper command and see the effect.



Expected Results:  
ChatZilla should display nicks and topics with the specified /charset. In other
words, /charset command covers not only channel and private messages/notices.

ChatZilla should recognize RFC 1459 commands of IRC protocol, especially /mode,
/notice, /trace, /stats.

ChatZilla should ask for IRC operator's password when /oper command is entered
and hide the password as it typed.

Dunno, whether it is connected event, but I have Mozilla 1.4 release, I download
latest ChatZilla, it's getting installed, I start it and can't type anything in
there. Version 0.8.13 supported user input normally.

Comment 1

14 years ago
You can see topic if you enter /topic.

bug 44423 for missing commands.

Comment 2

14 years ago
Confirming charset problem on ChatZilla 0.9.45
BTW, /me is not recoded either.
Leaving out missing command stuff since there is a separate bug 44423 for that
Platform/OS -> All/All
Changing Summary accordingly
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: FreeBSD → All
Hardware: PC → All
Summary: /charset problems, missing commands: /notice, /stats, /trace, /oper, /mode, /umode → nicks, actions, notices are not recoded according to charset
Product: Core → Other Applications

Comment 3

13 years ago
I think this is very bitrotten by now. I'm pretty sure topics, notices and
actions do get recoded (if not, it'd be trivial to implement it). While I'm at
it, I think nicknames also have some recoding done. I haven't actually tested
this (my Russian / Japanese is patchy at best), but I'm fairly sure this is a
FIXED bug, or if we can't pinpoint what fixed it, at least a WorksForMe.

Comment 4

13 years ago
Nicknames, actions and notices are currently decoded according to the prevailing
character encoding, and have been for a number of versions.

The current ChatZilla version is 0.9.68.5. Unless you can reproduce any problems
as described in this bug, on that (or newer) version, this bug is FIXED (bonsai
will tell you what by).
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

13 years ago
Created attachment 185545 [details]
demonstrates cyrillic nicks problem

[INFO]	Chatzilla 0.9.61 [Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.7.8)
Gecko/20050518]

as you can see, nicks are showing in ISO8859-1 encoding but they're in KOI8-R
really. Cyrillic chat windows works fine, except for nicks.
(Reporter)

Comment 6

13 years ago
alas, I have to reopen it. The attachment is an evidence of problem
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 7

13 years ago
Did you set the charset on the channel or the server? Nicknames are server-level
and you MUST set the charset on the server to the correct value.

Comment 8

13 years ago
Oh, and you're using an old ChatZilla. I don't think 0.9.61 has nickname
decoding at all! PLEASE use the VERSION I TOLD YOU TO USE before re-opening!
(Reporter)

Comment 9

13 years ago
well, I was using ChatZilla from Mozilla1.7.8 distro. Okay, now it really works,
thanks
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.