Mozilla loses or resets preferences irregulary, without wish to do that

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
critical
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: Thilo Straub, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624

When I use Mozilla 1.3, 1.21, 1.4 or Mozilla 1.5 alpha, doesn't matter which
Windows I use, Mozilla looses its preferences.
For example, "Internet Search", "Popup Windows", "Forms" and "Passwords" under
"privacy" are lost from time to time.

Reproducible: Always

Steps to Reproduce:
1. select Preferences like "Internet Search", "Popup Windows"...
2. Browse. Each day.
3. 

Actual Results:  
When Mozilla recognized that a popup windows wanted to appear, it asked me what
it should do though I blocked popup windows some days before.
I entered "Preferences" and could see that any of my set preferences was lost. I
had to reenter it again.

Expected Results:  
Mozilla should have kept its preferences though changing or resetting them.

I currently didn't have tested it under Windows 98 or OS/2 Warp 4/EcomStation
1.0 /1.1, but I will test this.
(Reporter)

Comment 1

15 years ago
Phenomen of loosing preferences occurs irregulary, sometimes after 4 weeks,
sometimes within a week.
(Reporter)

Comment 2

15 years ago
Mozilla looses or resets its preferences irregulary, sometimes under Windows in
4 weeks, sometimes within a week.
OS/2 Warp seems to be a little better, but I will test it again.
When Mozilla looses its preferences, I have to reenter the settings for my mail
and news-group-accounts.
it resets the file "prefs.js" in your profile. You can create a backup of this
and put it back if you get the problem (close Mozilla first).

Do you use PC Cillin on your windows System or do you lost the file after Mozila
and/or your system crashed ?
Summary: Mozilla looses or resets preferences inregulary, without wish to do that → Mozilla loses or resets preferences irregulary, without wish to do that

Comment 4

15 years ago
I can confirm the above craziness

I use 1.5a on WinXP

it all started after I was infected by the MSBlaster virus, but I do not
know if there is any link

actually, I had used moz 1.4 on WinXP for some time last here, and never seen
the problem

in only one case Mozilla showed me a dialog at boot, claiming that prefs.js
was damaged

Comment 5

15 years ago
It's possible that this is a dupe of bug 132517. Thilo, have you noticed that
when this problem starts happening, prefs.js in your profile is significantly
smaller than before? If so, then I think that bug is what affects you. It has a
patch awaiting review and will hopefully be fixed soon.

Comment 6

14 years ago
Resolving wfm, although this is probably a dupe of the bug I mentioned before.
Can't be sure without confirmation that prefs.js is truncated though. Please
feel free to reopen or comment if you can add new information about this in a
recent build.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.