main window can be closed when editing preferences

RESOLVED WONTFIX

Status

Thunderbird
Mail Window Front End
--
trivial
RESOLVED WONTFIX
15 years ago
15 years ago

People

(Reporter: Johan Prins, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 4.0)
Build Identifier: build 0.1

it's possible to close the main window when the preferences window is open...


Reproducible: Always

Steps to Reproduce:
1. open tbird
2. open preferences
3. click topright close button on main window

Actual Results:  
main window is closed / preferences still opened

Expected Results:  
disable close button or close preferences window also

Comment 1

15 years ago
I don't see how this is a bug. Prefs window is just like any other window. The
fact that it's not bound to thunderbird closely means that you can look through
your mail while trying to edit prefs. That's a good thing.

Suggest WONTFIX, but I'll leave that up to a developer to decide.
(Reporter)

Updated

15 years ago
Severity: normal → trivial
(Assignee)

Comment 2

15 years ago
The options window is just another application window and is not intended to be
modal.

I'm going to mark this as won't fix for right now but I will think some more on it. 

Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 3

15 years ago
- firebird has it as a modal window
- mozilla uses the same method as thunderbird.

...
You need to log in before you can comment on or make changes to this bug.