It stops seeing new mail until I completely restart Mozilla

RESOLVED WORKSFORME

Status

MailNews Core
Networking
RESOLVED WORKSFORME
15 years ago
10 years ago

People

(Reporter: Igor Velkov, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030718
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030718

Time to time (about one time in 3 days) Mozilla mail stops see (or show me) any
new mail. I have 2 pop account, one imap account. I works, read mails... Then I
dont got mails... No errors, I can see old messages in imap and local folders -
all looks corrects, like I simply haven't new mail. Then, I close all mozilla's
window (All - it does metter), then start mozilla again, run mail - and see 2
new mail in pop mailbox, and some new mails in imap folders - and they was there
some hours.

Reproducible: Sometimes

Steps to Reproduce:





It starts from 1.4 rc, not sure in rc1 or rc2. I am sure in isnt in 1.4 betas,
and it still in 1.4 release, and in 1.5a.

Comment 1

15 years ago
I upgraded to mozilla 1.5 release and also have this problem. 

I am using Windows XP Service Pack 1 with all the fixes applied from the
Microsoft Update site.

I've moved back to using Mozilla 1.4.1 which does not have the problem

Comment 2

15 years ago
I should also add that this bug is completely reproducible for me and it happens
whenever I receive new mail.

I get new mail
I can't read it
I restart Mozilla 1.5 
I can read it

I does not happen with 1.4.1 at all. I am using IMAP
(Reporter)

Comment 3

15 years ago
Confirm fully.

Updated

14 years ago
Summary: It stop see new mail until complitely restart mozilla → It stops seeing new mail until I completely restart Mozilla
(Reporter)

Comment 4

14 years ago
In 1.7.2 I not see this effect. 
(Reporter)

Comment 5

14 years ago
(In reply to comment #4)
> In 1.7.2 I not see this effect. 
Today I got this error, in 1.7.2.
Sorry for previous msg.

Comment 6

14 years ago
The symptoms mentioned in some of the comments might be bug 127461, a fix for
which got into 1.8a4.  Although that fix was for POP3 only, so maybe this is a
different problem.  

See bug 127461, comment 34 for instructions on determining if you are
experiencing that bug.  Or just give 1.8a4 a try to see if your problem still
occurs.  Please report any results.
(Reporter)

Comment 7

14 years ago
(In reply to comment #6)
> The symptoms mentioned in some of the comments might be bug 127461, a fix for
> which got into 1.8a4.  Although that fix was for POP3 only, so maybe this is a
> different problem.  
> 
> See bug 127461, comment 34 for instructions on determining if you are
> experiencing that bug.  Or just give 1.8a4 a try to see if your problem still
> occurs.  Please report any results.

I use 1.8a4 from time it was anounced on 3 different pc - at home, at work, and
mobile. I not see this effect on home pc for a long tima (maybe, 3 or 4 weeks),
but got this effect at work and laptop, last time was today - I see last new
message in my imap inbox about 16:00, then there was no new message until I
restart mozilla at 21 o'clock, then I see 7 new mails in my inboox, that arrived
from 16 to 21 o'clock.

Now I will try today's nightly build, like  Mike Cowperthwaite asks at
https://bugzilla.mozilla.org/show_bug.cgi?id=239874#c8

Comment 8

14 years ago
(In reply to comment #7)
> I see last new
> message in my imap inbox about 16:00, then there was no new message until I
> restart mozilla at 21 o'clock

Bug 127461 was a POP3 only fix, so obviously there is still some kind of problem
with IMAP.  Since moving to 1.8a4, are you still having problem with any of your
POP3 accounts, or are the problems only with IMAP accounts?
(Reporter)

Comment 9

14 years ago
(In reply to comment #8)
> with IMAP.  Since moving to 1.8a4, are you still having problem with any of your
> POP3 accounts, or are the problems only with IMAP accounts?

I can't remember, when I got this problem with pop3 account last time. I sure no
one incidents seen last 1 week. 

Product: MailNews → Core
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody

Comment 11

10 years ago
When you don't see new messages, do you also not see notification/indicator of new messages on folders?

You need to narrow down the cause by eliminating some of the possibilities:
* worked through http://kb.mozillazine.org/New_messages_do_not_appear
* change to two profiles and switch between the two, one with just pop and one with just imap, see which one hangs, then narrow it even further to a specific account
* if none of the above work, turn off system sleep/suspend/hibernate options (even screen saver)

and post results :)
QA Contact: grylchan → mailnews.networking
(Reporter)

Comment 12

10 years ago
Not see this bug very long time.
I propose to close, bug, maybe, as workforme.

Comment 13

10 years ago
=> WFM
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.