JSObject is broken in Linux.

RESOLVED WORKSFORME

Status

--
blocker
RESOLVED WORKSFORME
15 years ago
8 years ago

People

(Reporter: pgupta, Assigned: yuanyi21)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: redesign)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3.1) Gecko/20030425
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3.1) Gecko/20030425

I am developing a tool. I use Java and Javascript in that tool.  I am calling
JavaScript function in Java file using JSObject ( win.eval() ) method.  In my
Java file I am using applet.  In Java Applet, I have a Run button. When I click
the Run button then JavaScript function should get executed. but nothin happens
and mozill a is freez.  This only happen in LINUX it works PERFECT on win2k. It
would very helpful if anyone can help me with that. I am using Mozilla 1.3 and
JRE 1.4 ( I also tryied JRE1.3 as well )

Reproducible: Always

Steps to Reproduce:
1.In applet hit the Run button
2.Browser froze. 
3.

Actual Results:  
Browser Froze , I have to reboot the machine or kill the process in linux. 


OJIPlugin acq Spontaneous pipe=10
Trying to enter spont monitor: 0
 OJIPlugin release for:Thread[thread applet-TMain.class,4,file:....-threadGroup]
OJIPlugin releasePipe - exiting spont monitor
Current thread:Thread[thread applet-TMain.class,4,file: ... /LiveCo
nnect/-threadGroup]
OJIPlugin: No AThread

Comment 1

15 years ago
Reassigning to OJI component -
Assignee: nboyd → joshua.xia
Component: Compiler → OJI
Product: Rhino → Browser
QA Contact: pschwartau → dsirnapalli
Summary: JSObject is broken in Linux. → JSObject is broken in Linux.
Version: other → Trunk

Comment 2

15 years ago
Please provide your testcase!
Thanks!
Status: NEW → ASSIGNED

Comment 3

15 years ago
*** Bug 215054 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Whiteboard: redesign

Comment 4

15 years ago
->kyle
Assignee: joshua.xia → kyle.yuan
Status: ASSIGNED → NEW

Comment 5

15 years ago
JSObject.eval should work fine with JRE 1.4 on Linux.

Reporter, you may need to put a simplified testcase here to let us identify the
problem.

Comment 6

15 years ago
I'm looking for a another bug which describes this, but my findings have been
that LiveConnect (JSObject, et al) are broken in 1.4.2_03 (or whatever the
current release is), but worked OK in 1.4.2 betas.  (I think it was also broken
in 1.4.2_02).

I've been running these against mozilla 1.5, and firebird 0.7.

Currently, I've downgraded to j2sdk-1.4.2-rc1-linux-i586-gcc3.2.bin from
blackdown (because I can't figure out how to get the older versions from sun).


Comment 7

15 years ago
Sorry for the premature bugspam.

The previous message may be invalid:  After reading through more java bugs, I
thought that 1.5 (j2sdk-1_5_0-beta-bin-b31-linux-i586-11_dec_2003.bin) might fix
the problem, but it didn't.

When it did not, I turned on more debugging in the java console, and found the
applet was not even loading.  Changing the applet tag from specifying "width=0
height=0" to small positive integers caused the applet to load, and liveconnect
to more or less work.  I expect that the same may work for 1.4.2_03, etc.

I wonder if it's a bug that applets don't load when they are set to zero
height/width..  (it's certainly new behavior).

(Assignee)

Comment 8

15 years ago
JSObject works fine for me. Feel free to reopen it if you are still seeing the
*similar* problem.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.