Installing Sun Java 1.4.2 plugin prevents Firebird 0.6.1 from starting up

RESOLVED INVALID

Status

()

Firefox
General
--
critical
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: Jeremy Jongsma, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

After installing the Sun Java 1.4.2 plugin, Firebird 0.6.1 will not run.  It
immediately exits with an error message.

Worked fine in 0.6.

Reproducible: Always

Steps to Reproduce:
1.  Install Firebird 0.6.1 and Java 1.4.2 on Linux
2.  Create symbolic link to jre/plugin/i386/ns610/libjavaplugin_oji.so in
Firebird's plugins/ directory
3.  Execute MozillaFirebird from the firebird directory.

Actual Results:  
The following erorr message displayed, and the browser would not start:

---
INTERNAL ERROR on Browser End: No manager for initializing factory?

System error?:: Success
---

Expected Results:  
Start up and let me use Java.

Comment 1

14 years ago
The Sun j2sdk1.4.2 libjavaplugin_oji.so also does work on Mozilla 1.5 alpha
when you provide a symbolic link to under the plug-ins directory.

The browser appears to hang forever

This is the typical command I used

ln -sf /usr/local/j2sdk1.4.2/jre/plugin/i386/ns610/libjavaplugin_oji.so 
/opt/mozilla1.5a/plugins

David, I know you're on Linux, how is this working for for you?

*** This bug has been marked as a duplicate of 216411 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
QA Contact: asa → mpconnor
Resolution: --- → DUPLICATE
oops, backwards
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
*** Bug 216411 has been marked as a duplicate of this bug. ***
-> critical
Severity: major → critical
new based on dupes
Status: UNCONFIRMED → NEW
Ever confirmed: true
*** Bug 216942 has been marked as a duplicate of this bug. ***

Comment 8

14 years ago
I wonder when this bug will be fixed in a nightly...

i'm going to wait until it is said it's fixed.

Comment 9

14 years ago
Well, Mozilla-Firebird 0.6.1 and Java works for me (Linux 2.4.20, Debian
testing/unstable):

libjavaplugin_oji.so ->
/usr/local/java/jre/plugin/i386/ns610-gcc32/libjavaplugin_oji.so

The difference is, that i use the plugin from the ns610-gcc32 directory. My
java-sdk is:

$ java -version 
java version "1.4.2_01"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_01-b06)
Java HotSpot(TM) Client VM (build 1.4.2_01-b06, mixed mode)

But i have had problems with Firebird and an old Mozilla-Installation (1.4)
While Mozilla-Firebird works for me only with the plugin from the 'ns610-gcc32'
plugin directory, my old Mozilla wants the plugin from the ns610 directory.

Mozilla-Firebird browses "~/.mozilla/plugins" (see 'strace Mozilla-Firebird' ,
and uses the javaplugin found there and ignores my plugin in
"/usr/lib/mozilla-firebird/plugins". 

When i remove the plugin from "~/.mozilla/plugins" or when i set the link to the
plugin from the ns610-gcc32 directory instead, Mozilla-Firebird will startup.
(But my old mozilla will spew me from now on with error messages when trying to
load the plugin.)

Maybe the problem will just disappear, when both, Mozilla and Firebird, can
use the same plugin again. Does it depend on the compiler used for compiling
Mozilla and Firebird only, or is it more complex? 

Anyways, i found out for me the following workarounds:

1. Delete the old mozilla-installation. YAY! Or make a backup!

2. Instead of deleting the whole mozilla-installation, i removed just the link
to the javaplugin from the ns610 plugin directory. Mozilla won't work
with java anymore, but i have peace with Firebird.

3. I wait for a mozilla-version, which can use the plugin from the ns610-gcc32
directory. I think, this will never gonna happen, because firebird will replace
Mozilla? Well, and when it happens, the current plugin link has to replaced
anyways in the mozilla-directory.

My last question:

Is Mozilla-Firebird browsing "~/.phoenix/plugins" ? At least a link there does
not override the plugin from "~/.mozilla/plugins". 

Mh!

Comment 10

14 years ago
Firebird 0.6.1 and Java Plugin doesn't work for me.  I get the same
error message.  The previous build of Firebird worked very nicely with
Java plugin.  I'm running RedHat 7.3 Linux 2.4.18-3.

If I try to use the plugin from the ns610-gcc32 directory instead,
Mozilla-Firebird will startup, but the plugin still doesn't work
because it gets this error:

LoadPlugin: failed to initialize shared library
/usr/local/MozillaFirebird/plugins/libjavaplugin_oji.so [libgcc_s.so.1: cannot
open shared object file: No such file or directory]

Comment 11

14 years ago
Do you have the file:"/usr/lib/libgcc_s.so" ?

If you are lacking of this file, the share library cannot work totally.
(This library can find on your install cd)

Comment 12

14 years ago
The 0917 nightly didn't start for me when I had the NewsMonster extension
installed.  I removed it, restarted successfully, and then went to a java test
page (http://www.help4web.net/webmaster/Java/).  At that point Firebird would
crash, with the following error:

INTERNAL ERROR on Browser End: JavaPluginInstance5::GetValue - Not implemented
System error?:: Success

I am using the gcc32 java plugin of jre 1.4.2.

Comment 13

14 years ago
I'm running RH7.3, firebird 6.1 and installed jre131_02.xpi.
When firebird is started from de command line it is printing this error twice :

LoadPlugin: failed to initialize shared library
/usr/local/MozillaFirebird/plugins/java2/plugin/i386/ns600/libjavaplugin_oji.so
[/usr/local/MozillaFirebird/plugins/java2/plugin/i386/ns600/libjavaplugin_oji.so:
undefined symbol: __vt_17nsGetServiceByCID]

Hope this is userfull.

Comment 14

14 years ago
Mike, is there a reason for keeping this open.  Should be resolved->invalid. 
Original reporter is using the wrong plugin (should use
$JRE/plugin/i386/ns610-gcc32/libjavaplugin_oji.so).

Comment #12 sounds like a dupe of Bug 219705.

Comment #9 confirms that this works using the correct plugin.

good point, ns610 is gcc 2.9x compatible, hence the problem

I need to load up Linux and retriage a bunch of *nix-specific bugs in the next
couple of days

.

Status: NEW → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.