Bookmarks in HTML-mails don't work properly

RESOLVED DUPLICATE of bug 216154

Status

SeaMonkey
MailNews: Message Display
--
major
RESOLVED DUPLICATE of bug 216154
15 years ago
13 years ago

People

(Reporter: Bernhard Goebl, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030718
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030718

Bookmarks in HTML-mails don't work anymore in Mozilla 1.5alpha but did in 1.4final

An example for the source:
<LI> <font face=3D"Verdana, Arial, Helvetica, sans-serif" size=3D"-1"> <a h=
ref=3D"#1">DBConcepts: "speeding up your application development"</a><br>Da=
tenbankspezialist bringt Entwicklersuite auf den Markt (pts030729002)<br>&n=
bsp;</font></LI>

In 1.4 the following local URL was generated (personal info modified):
mailbox:///D|/Data/Mozilla/abc12345.slt/Mail/accountname/Pressestext?number=170405315#1

In 1.5 it looks like this:
/#1

The bookmark does not work anymore and causes an error message (Alert - is not a
registered protocol).



Reproducible: Always

Steps to Reproduce:
1. open mail
2. click bookmark
3.

Actual Results:  
URL shows as /#1 - clicking shows message box titled "Alert" with the message
"is not a registered protocol" and an OK-button.

Expected Results:  
URL should show as
mailbox:///D|/Data/Mozilla/abc12345.slt/Mail/accountname/Pressestext?number=170405315#1
and jump to bookmark if clicked.
(Reporter)

Comment 1

15 years ago
Created attachment 128837 [details]
Mail-file to reproduce the error

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 216154 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.