If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

ability to sort bookmarks by access frequency

VERIFIED WONTFIX

Status

()

Firefox
Bookmarks & History
--
enhancement
VERIFIED WONTFIX
14 years ago
12 years ago

People

(Reporter: Sebastian Michailidis, Assigned: Pierre Chanial)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

how about ordering bookmarks dynamical by the criterion "links used most often".
so the more often you click on a link in your bookmarks, the higher it will get
ranked and the higher it will get displayed. in the first time this might become
confusing and distracting since stuff will change all the time, but as time goes
by there will evolve a clear order which enables efficient use of your bookmarks.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.




Would be nice to have this in firebird... ;)
I'd like to work on this. I don't guarantee it will be done fast, since I still
have to get familiar with the code related to this.
(Reporter)

Comment 2

14 years ago
was ment for firebird
Component: Bookmarks → Bookmarks
Product: Browser → Firebird
Version: Trunk → unspecified
This is much more suited to be an extension.  This requires adding information
to the bookmarks service such as number of times visited, as well as dynamically
modifying the contents of bookmarks.html at whatever interval the optimization
would take place.  This is a lot of code, and since it certainly wouldn't be the
default behaviour, it belongs outside of the FB core.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX

Comment 4

14 years ago
VERIFYING obvious WONTFIX bugs.  Filter on firebirdWontFix to filter these bugs.
 I skipped a few that I'm unsure about from their summary and will manually go
through them.
Status: RESOLVED → VERIFIED

Updated

14 years ago
QA Contact: petersen → bugzilla

Updated

13 years ago
Summary: feature request: Bookmark sorting criterion "sort by personal popularity" → ability to sort bookmarks by access frequency

Updated

12 years ago
QA Contact: bugzilla → bookmarks
You need to log in before you can comment on or make changes to this bug.