If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Mail Filter "Marks As Read" does not mark the Folder as read

VERIFIED DUPLICATE of bug 179556

Status

Thunderbird
Mail Window Front End
VERIFIED DUPLICATE of bug 179556
14 years ago
13 years ago

People

(Reporter: Dave Evans, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4; MultiZilla v1.4.0.4A) Gecko/20030624
Build Identifier: Mozilla Thunderbird 0.1 (20030723)

I believe this is related to bug 179556, and I haven't seen anything that sites
Thunderbird directly ... so I wanted to file this report.

- When using a filter to set "Mark the Message As Read" it does not mark the
message itself as read
   - however it does mark the folder its in as having an unread message
   - it also has this little icon with a little green down arrow
   - the arrow goes away once you read the message, and then leave the folder
   	- however it doesn't go away if you switch to another message in the folder


Reproducible: Always

Steps to Reproduce:
1.Setup a filter to move an email to a folder, and mark as read
2.Email comes in, and is caught by the filter, and moved to the proper folder.
3.It is also "de-bolded"
4.However the it has a "new mail" icon, and the folder IS bolded
5.I go to the folder find the "new" message, and read it
6.the folder status doesn't change once i flip to another message
7.I then go to another folder.
8.Then everything is finally marked as read



Expected Results:  
Both the message's icon and the folder's bold state should be marked as read as
well.
(Assignee)

Comment 1

14 years ago
sounds like a dup.

*** This bug has been marked as a duplicate of 179556 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.