Status

--
blocker
RESOLVED FIXED
16 years ago
9 years ago

People

(Reporter: tenthumbs, Assigned: dougt)

Tracking

({smoketest})

Trunk
smoketest

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Any attempt at viewing page source fails with a dialog box that says
 "/tmp/<randomname> cannot be saved because the source file could not be read
etc."

Well, /tmp really does have 1777 permissions so that's not the problem. I do see
this:
  WARNING: NS_ENSURE_TRUE(encodedChannel) failed, \
    file nsExternalHelperAppService.cpp, line 1233

which is why I'm starting this in file handling.

Linux trunk build just 3 hours old.

Comment 1

16 years ago
I can confirm this bug on Windows XP.
posibble regression from bug 199335

Comment 3

16 years ago
yes, instead of adding the ability to exclude view source, it's now excluded
everywhere :(

Comment 4

16 years ago
thanks dougt. please fix this before we respin or i will back this out.
Assignee: law → dougt
Severity: normal → blocker
Component: File Handling → ViewSource
Depends on: 199335
OS: Linux → All
QA Contact: petersen → doron
Hardware: PC → All
(Assignee)

Comment 5

16 years ago
i won't have too much time until tonight to look at this.

1) are these clobber builds that you are reporting the problme with?
2) if so, and you cant find a fix, back it out and I will correctly fix it later.

Comment 6

16 years ago
it fails in the smoketest builds. w32 2003073004. the changes were backed out.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Keywords: smoketest
Resolution: --- → FIXED
*** Bug 214644 has been marked as a duplicate of this bug. ***
*** Bug 214691 has been marked as a duplicate of this bug. ***
*** Bug 214692 has been marked as a duplicate of this bug. ***
*** Bug 214733 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey

Updated

9 years ago
Component: View Source → View Source
Product: SeaMonkey → Core Graveyard
You need to log in before you can comment on or make changes to this bug.