Display error when div inside table, heights both set to a %

RESOLVED DUPLICATE of bug 210657

Status

()

RESOLVED DUPLICATE of bug 210657
15 years ago
15 years ago

People

(Reporter: lfishrd, Assigned: bugzilla)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

On test2.html the table height is set to 100%, inside a cell in said table there
is a div with a style attribute set to overflow:scroll;height:80%;

If the div is not in a table, it displays fine with it only taking up 80% of the
page, but placing it into the table with height at 100% cause it to bleed way
down past the 80%

Reproducible: Always

Steps to Reproduce:
1.Create a table with height set to 100%
2.Place a div tag in a cell of the table with style set to
"overflow:scroll;height:80%;"

Actual Results:  
It displayed incorrectly. Cause the viewer to scroll down to see the entire div.

Expected Results:  
The table should take up 100% of the height of the page, and the div taking up
80% of the table, thus 80% of the page.

I created Test2.html (link above) to demonstrate the bug.

Comment 1

15 years ago
The URL given is a 404.

Have you tested this in Mozilla proper?  I would bet they render the same, in
which case this is not a Firebird-specific bug.
(Reporter)

Comment 2

15 years ago
I appologize I put .html instead of .htm. The link should now work.
(Reporter)

Comment 3

15 years ago
Okay, I downloaded mozilla proper; Looks like it happens in mozilla too. I am
going to change it from Firebird to Mozilla
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624
Component: General → Layout: Tables
Product: Firebird → Browser
Version: unspecified → 1.4 Branch

Comment 4

15 years ago
I can see this problem with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030801
->Trunk.

Is this a a dupe of bug 210657?
Version: 1.4 Branch → Trunk
(Reporter)

Comment 5

15 years ago

*** This bug has been marked as a duplicate of 210657 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.