Browser Included IE Conditional Comments

RESOLVED INVALID

Status

SeaMonkey
General
--
minor
RESOLVED INVALID
15 years ago
13 years ago

People

(Reporter: Bill Creswell, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

IE conditional comments to correct IE 5/5.5 box models were applied by Firebird 6.1
http://www.netpenny.net/users/bcreswell/CSS/VECSS/vetestcss5.htm

<![if lte IE 5.5000]>  <style type="text/css" media="screen">
 .tableedge {margin-left:-3px;margin-right:-3px;}
 .tabedge {margin-left:-3px;margin-right:-3px;}
 </style>
 <![endif]>

Reproducible: Always

Steps to Reproduce:
1.Applied Conditional Comments for IE Browsers
2.Loaded Page in Firebird
3.

Actual Results:  
Firebird Applied conditional comments to page.

Expected Results:  
ignored conditional comments, or applied them appropriately. (if N5 condition)

Comment 1

15 years ago
The syntax you give is for what Microsoft call a downlevel-revealed conditional 
comment. If you want a conforming browser to ignore it use the <!--[ form.

"<!--[if" looks like a comment to Mozilla, "<![if" a syntax error
(Reporter)

Comment 2

15 years ago
Son-of-a-blank, you're right, I'm so sorry and thanks for looking into it. Keep
up the excellent work!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.