does not accept the + char in field: Account Settings -> Account Name

RESOLVED WORKSFORME

Status

Thunderbird
Account Manager
--
blocker
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: Daniel Proietti, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

For some strange reason my email provider requires the use of  + char instead of
the @ char in the account name.  

For example i put danp+onlinerestaurantmenu.com in the account field which
Thunderbird accepts but when it attempts to connect it uses
danp@onlinerestaurantmenu.com.

Reproducible: Always

Steps to Reproduce:
1. create an account with a plus in the user account field (the account for on
the mail server) ex danp+onlinerestaurantmenu.com
2. Attempt to get mail and the app uses danp@onlinerestaurantmenu.com instead of
danp+onlinerestaurantmenu.com
3. 

Actual Results:  
Can't connect to server because it uses the danp@onlinerestaurantmenu.com
account instead of danp+onlinerestaurantmenu.com



Expected Results:  
should use the danp+onlinerestaurantmenu.com account to connect

Comment 1

15 years ago
I use that system. I have a 'main' login, which is a catchall - it catches all
mail that does not go too any other mailboxes. That is just 'xyz'. I then have
various other pop boxes, but for those i have to do: sales+xyz.com,
support+xyz.com etc. And it works just fine.

WFM.
Summary: does not accept the + char in field: Account Settings -> Account Name → does not accept the + char in field: Account Settings -> Account Name

Comment 2

15 years ago
WFM too...

Comment 3

15 years ago
Daniel, maybe you are mixing up "Account Name" and "User Name"? "Account Name"
is the name that Thunderbird displays for your account in the folder pane and
various other places. You can type in whatever you like making it easy for you
to recognize the account.
The "User Name" (Account settings > Server Settings) is used when connceting to
the server and fetching mails. This has to be correct in order to get your mails.

Make sure you have the right user name under "Server Settings". If it doesn't
work, please provide the error message. I suppose your settings aren't correct.

Updated

15 years ago
QA Contact: asa

Comment 4

14 years ago
I still see this bug listed as Status: NEW Severity: blocker.  I'd like to put
this to rest once and for all.

First, the setup:

user_pref("mail.server.server3.directory",
"/home/todd/.thunderbird/default/dr05kwjf.slt/Mail/localhost");
user_pref("mail.server.server3.directory-rel", "[ProfD]Mail/localhost");
user_pref("mail.server.server3.hostname", "localhost");
user_pref("mail.server.server3.name", "mozilla@brainsick.com");
user_pref("mail.server.server3.port", 1234);
user_pref("mail.server.server3.type", "pop3");
user_pref("mail.server.server3.userName", "mozilla+brainsick.com");

-----

[todd@color:/home/todd]> cat nc-mail.sh
#!/bin/sh
 
/usr/local/bin/nc -w 3 -o test2.log mail.brainsick.com 110

-----

[todd@color:/home/todd]> nc -v -p 1234 -l -e ./nc-mail.sh
listening on [any] 1234 ...

-----

I then instruct Thunderbird to 'Get Mail'.

-----

Now, the results:

[todd@color:/home/todd]> cat test2.log
< 00000000 2b 4f 4b 20 50 4f 50 33 20 5b 63 70 70 6f 70 20 # +OK POP3 [cppop
< 00000010 39 2e 39 5d 20 61 74 20 5b 36 33 2e 32 34 37 2e # 9.9] at [63.247.
< 00000020 31 33 35 2e 32 31 32 5d 0d 0a                   # 135.212]..
> 00000000 43 41 50 41 0d 0a                               # CAPA..
< 0000002a 2b 4f 4b 20 43 61 70 61 62 69 6c 69 74 79 20 6c # +OK Capability l
< 0000003a 69 73 74 20 66 6f 6c 6c 6f 77 73 0d 0a          # ist follows..
< 00000047 54 4f 50 0d 0a 55 53 45 52 0d 0a 55 49 44 4c 0d # TOP..USER..UIDL.
< 00000057 0a 58 53 45 4e 44 45 52 0d 0a 49 4d 50 4c 45 4d # .XSENDER..IMPLEM
< 00000067 45 4e 54 41 54 49 4f 4e 20 63 70 70 6f 70 0d 0a # ENTATION cppop..
< 00000077 2e 0d 0a                                        # ...
> 00000006 55 53 45 52 20 6d 6f 7a 69 6c 6c 61 2b 62 72 61 # USER mozilla+bra
> 00000016 69 6e 73 69 63 6b 2e 63 6f 6d 0d 0a             # insick.com..
< 0000007a 2b 4f 4b 20 4e 65 65 64 20 61 20 70 61 73 73 77 # +OK Need a passw
< 0000008a 6f 72 64 0d 0a                                  # ord..
> 00000022 50 41 53 53 20 74 65 73 74 69 6e 67 0d 0a       # PASS testing..
< 0000008f 2d 45 52 52 20 55 73 65 72 6e 61 6d 65 2f 50 61 # -ERR Username/Pa
< 0000009f 73 73 77 6f 72 64 20 4d 69 73 6d 61 74 63 68 20 # ssword Mismatch
< 000000af 70 65 72 68 61 70 73 20 6d 6f 7a 69 6c 6c 61 40 # perhaps mozilla@
< 000000bf 79 6f 75 72 64 6f 6d 61 69 6e 2e 63 6f 6d 20 3f # yourdomain.com ?
< 000000cf 0d 0a                                           # ..

-----

The log clearly shows that the username is being supplied as
mozilla+brainsick.com just as the account was setup.

This works for me in Thunderbird 0.6 but I've been using user+domain.com e-mail
addresses since Thunderbird 0.2.  Let's close this.
(Assignee)

Comment 5

14 years ago
cool
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.