Location box requires more than a double-click to hilite initially.

VERIFIED DUPLICATE of bug 20192

Status

()

Core
Selection
P3
normal
VERIFIED DUPLICATE of bug 20192
18 years ago
18 years ago

People

(Reporter: WD, Assigned: mjudge)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Overview Description:

When first loading up Mozilla, if the Location box at the top is double-
clicked, the text (http://www.mozilla.org) is not selected.   A 2nd double-
click is required.

Steps to reproduce:
Load Up Mozilla
Double-click on the Location box

Actual results:
The cursor is moved from the beginning of the Location box to the end.  After a
subsequent double-click, the text is selected.

Expected results:
The entire text of the Location box is selected after the first double-click.

Build Date & Platform:
Mozilla build 1999121008
Windows 98, Windows 95

Additional information:
In actuality, the a double-click is not necessary the first time...  A single
click to get the Location box's focus, and then a following double click will
hilite the text.

The reason I find this unexpected is that with Netscape, you can double click on
the Location box to hilite it immediately after loading it, without having to
click on it before double-clicking to get the focus.     (boy, that's a
mouthful!!)

-WD

Updated

18 years ago
Assignee: leger → mjudge
Component: Browser-General → Selection
QA Contact: leger → elig

Comment 1

18 years ago
[moving over to correct component/engineers.]

This is probably a duplicate of the general focus bug that's being dealt with,
but I'll defer to mjudge to be sure. Thanks!

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
this is a dup of 20192

*** This bug has been marked as a duplicate of 20192 ***

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 3

18 years ago
Verifying as duplicate.
You need to log in before you can comment on or make changes to this bug.