window size unappropriate for big fonts

RESOLVED FIXED in Thunderbird0.8

Status

Thunderbird
Mail Window Front End
RESOLVED FIXED
15 years ago
12 years ago

People

(Reporter: Arnaud Ladrière, Assigned: Stefan Borggraefe)

Tracking

unspecified
Thunderbird0.8

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

I'm using Thunderbird, and wy windows 2000 is configured with big fonts. The
problem is that most of the window that open are too small to display the entire
content. Usually this is not a real problem as many of them are resizable, but
for the window which are not resizable, it may become very unconvenient because
some buttons are "lost".

Reproducible: Always

Steps to Reproduce:
1. select big fonts (125%)in windows display prefs (reboot if necessary)
2. open thunderbird
3. open any window



Expected Results:  
Thunderbird should calculate the default size of the window, taking in account
the size of the system font.

Comment 1

15 years ago
Guessing this is related/based on bug 214205. There aren't that many windows
that can't be resized, other than the about box. If that's the only one, then
this should be marked as a dupe. Marking as blocker for that one.
Blocks: 214205

Updated

15 years ago
QA Contact: asa
(Reporter)

Comment 2

14 years ago
I agree that most windows are resizable, but the default opening size should be
wisely calculated, otherwise the feedback on the whole program will be : "I must
resize every window I open, this is boring, then I'll use a more clever program
like (name any competitor)".

My two cents : usability ARE the most important features

Comment 3

14 years ago
(Windows XP) I have the exact same problem, but I'm not even using larger fonts,
just a wider font. Instead of the standard Tahoma 8pt I am using Lucida Grande 8pt.

For example, the Account Settings shows very poorly. I can't even see the
Advanced button in Server Settings, so I can't get in to set my IMAP server
folder. This whole section (Account Settings) cannot be resized to fit.
No longer blocks: 214205
(Assignee)

Comment 4

14 years ago
Created attachment 151997 [details] [diff] [review]
Port of bug 99264 and bug 221665 to TB

This patch fixes the following windows: Subscribe, Search Addresses and Search
Messages.

I already fixed these windows for Seamonkey (see bug 99264 and bug 221665).
This is a port of these fixes, so this should be pretty save. I tested it with
TB nonetheless of course.

Discussion about the window size of the Account Settings dialog is in bug
233028 and bug 82122.

Are there any other windows that need to be fixed?
Assignee: mscott → Stefan.Borggraefe
Status: NEW → ASSIGNED
(Assignee)

Updated

14 years ago
Attachment #151997 - Flags: review?(mscott)
(Assignee)

Updated

14 years ago
OS: Windows 2000 → All
Hardware: PC → All

Comment 5

14 years ago
Comment on attachment 151997 [details] [diff] [review]
Port of bug 99264 and bug 221665 to TB

Thanks a lot for porting this fix Stefan.
Attachment #151997 - Flags: superreview+
Attachment #151997 - Flags: review?(mscott)
Attachment #151997 - Flags: review+

Comment 6

14 years ago
fixed branch and trunk
Target Milestone: --- → Thunderbird0.8

Comment 7

14 years ago
I meant to close this. 
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 8

12 years ago
In Linux Thunderbird 1.5.0.5 () almost all dialogs, at least in Preferences, are too small when the system has been configured to use a larger than default font.
You need to log in before you can comment on or make changes to this bug.