If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

browser hangs upon clicking "enter chat"

RESOLVED INVALID

Status

SeaMonkey
General
--
critical
RESOLVED INVALID
14 years ago
13 years ago

People

(Reporter: mozilla, Unassigned)

Tracking

Trunk
x86
FreeBSD

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.3) Gecko/20030430
Build Identifier: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.3) Gecko/20030430

This may be related to 200844 or possibly a duplicate; however, 200844 describes
a crash on Mac, whereas this is a hang under FreeBSD and also Windows XP, in
both cases using the Sun Java plug-in.

When going to the URL, a pop-up "messenger" window appears, and after the applet
loads, clicking on "enter chat" hangs the browser... though it's not very easy
to understand why.

Clicking on the button should load /messenger/cmd.html?op=roomList in a window.

Reproducible: Always

Steps to Reproduce:
1. Load http://www.gay.com/chat/ making sure to allow pop-ups.
2. Wait for the applet to load
3. Click on "enter chat"

Actual Results:  
Browser hangs

Expected Results:  
Browser does not hang; a window with a room listing is displayed.

This also happens to 1.4 under Windows XP.
(Reporter)

Comment 1

14 years ago
This might actually be one part evangelism; I managed to pull down their
javascript on the cmd.html page using another browser:

case ('roomList'):
   // May need to retry a few times, if applet was disabled and has not yet
finished loading.
   if (attemptCount< 10) {
      if (parent.gcom_messenger_applet && parent.gcom_messenger_applet.loaded &&
          parent.gcom_messenger_applet.document.applets.messenger &&
          parent.gcom_messenger_applet.document.applets.messenger.isActive() ) {
  
  window.parent.gcom_messenger_applet.document.applets.messenger.showRoomList();
            attemptCount=0;
          } else {
//setTimeout('window.parent.gcom_messenger_applet.document.applets.messenger.showRoomList()',
1500);
            setTimeout('doCmd()', 1500);
            attemptCount+=1;
      }
    } else {
      attemptCount=0;
    }

Looks rather like an infinite loop to me.  The strange thing, though, is that
you'd think if the setTimeout function were being handled properly, the browser
wouldn't hang because it would only be trying that function every 1.5 seconds.

Still something fishy...

Comment 2

14 years ago
Just a side comment about gay.com chat, it's a POS, and so is the handling for
gay.com's popup for it.  Goto http://www.gayboi.net/ and use the chat client
from there.

I would be tempted to mark this as "wontfix" but I won't [yet].  Mozilla isn't
the only browser that has issues, but I will agree that there are a lot of java
issues with mozilla.

For me, the java applet will load, but it just doesn't function, the room and
member lists never populate.

Reporter, will you please try this again with a current build of Mozilla and
provide your comments about whether or not this problem still exists?
Product: Browser → Seamonkey
Reporter did not respond.  If this is still a problem please reopen and
redocument steps to reproduce.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.