Closed Bug 21461 Opened 20 years ago Closed 19 years ago

Mozilla doesn't show background colour of outer of two nested tables

Categories

(Core :: Layout: Tables, defect, P3)

x86
Linux
defect

Tracking

()

RESOLVED FIXED
Future

People

(Reporter: norwolf, Assigned: karnaze)

References

()

Details

(Keywords: testcase)

Attachments

(6 files)

The tables in the right part of the web page is not shown correctly.
Thanks for the information. However, could you be more specific about the
problem? And, is it possible for you to isolate the problem in a smaller
testcase as an attachment to the bug? If you need help with this, please consult
the bug writing guidelines located at:

http://www.mozilla.org/quality/bug-writing-guidelines.html
Unable to connect to mentioned URL due to restricted access.
User name: ola
Password: nordmann

The site is also public at http://nlc.no
Status: NEW → ASSIGNED
Target Milestone: M15
Summary: Mozilla doesn't show the tables as it should → [4.xP] Mozilla doesn't show background colour of outer of two nested tables
Whiteboard: [TESTCASE]
OK. The table which holds the images on the right looked OK to me in M12, but
the nested table trick he uses in the centre of the page to get a black border
round a section of text doesn't work in M12, so I've created a test case for
this and marked this bug [4.xP].

If you remove any of the CELLPADDING or CELLSPACING values for the tables, M12
starts producing the "correct" black border behaviour.

Bug 23810 is a similar problem, but I don't think it's a dupe.

Hope this is of some help (and that it's the bug originally filed ;-)

Gerv
Bulk moving [testcase] code to new testcase keyword. Sorry for the spam!
Keywords: testcase
Setting the keyword all open [4.xp] bugs to 4xp.
Keywords: 4xp
Summary: [4.xP] Mozilla doesn't show background colour of outer of two nested tables → Mozilla doesn't show background colour of outer of two nested tables
Whiteboard: [TESTCASE]
Verified still a problem in W95 2000021615.

Gerv
Still a problem on 20000324 W95 <sigh>.

Gerv
mass move to m16
Target Milestone: M15 → M16
Moving to M17
Target Milestone: M16 → M17
The attachment looks like IE although not like Nav4.7.

This bug has been marked "future" because the original netscape engineer working 
on this is over-burdened. If you feel this is an error, that you or another 
known resource will be working on this bug,or if it blocks your work in some way 
-- please attach your concern to the bug for reconsideration. 
Target Milestone: M17 → Future
I don't see a problem here. The table in the background has a black
background-color. OK. The table inside is white. OK. What would make the black
color show? the distance between the border of the black cell and the inner
table. How do you do this? by setting CELLPADDING="1" in the outer table. This
creates a 1-px black border. The cellpadding in the inner table will only move
the text away from the black border.

I agree, there is a black border showing in Netscape 4.x, but it doesn't either
in IE 5.5. Therefore, I think it is rather a bug in Netscape 4.x than a bug in
Mozilla.

I suggest to mark this Bug as INVALID.
I see this problem a lot for some of my web pages, where I use a table with
cellpadding, cellspacing and border set to zero, and one cell with a background
of black. Creating a table inside with cellspacing=1 but the others as zero
usually (under Netscape 4.x and IE) produces a table with a thin black line
separating the cells, which I think is more visually appealing than the default
table style. However, in Mozilla under linux (but NOT under Windows), some of
these black lines disappear.

As I said, it works fine under Netscape 4.x, IE 5.5 and Mozilla/Win98, so I
don't think this should be INVALID. I will attach my (not wonderful) HTML which
illustrates the problem, although the first attachment is much more succinct.
Attached file Another test case
Testcase of 11/07/00 working great on Linux Trunk build 2000110521. Simon King,
if you still don't see this with a new build correctly, then reopen the bug.
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → WORKSFORME
The problem is still there in build 2000110721. I'm not sure I explained the
problem correctly - perhaps I should attach screenshots. What you see under
Netscape 4.72 is a table with a black border and black lines between each of the
cells. However, in Mozilla (Linux only) the black lines disappear from between
the two white rows, and also from the bottom.

When I was looking for other bugs like this one, I found one (sorry, I can't
remember the number now) which sounded similar but seemed to depend on whether
reflow had happened while the table was being layed out, and that depended on
the download speed - perhaps that is why you see different results than me.

In one of the previous comments, you talk about setting CELLPADDING=1 in the
outer table - this gives the black outer border but not black lines between
cells. In my testcase, the inner table uses CELLSPACING=1 to get the desired
effect. I don't know whether that should make a difference.

If you have Netscape 4.x as well as Mozilla, try looking at the testcase in both
and tell me if you see a difference - otherwise I will attach screenshots.

Er, I'd like to reopen the bug, but I don't think I have permission - perhaps
you could do it for me?

Cheers
Reopening because of Simon's comments. Simon, yes please, do attach a screenshot
of the page like you see it and like you would like to see it. I don't have
Linux, but I asked people on #mozilla and #mozillazine and they said it lays out
correctly. So screenshots are really needed to dig that. Be sure to use the
lates build. Thanx.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
OK, I've created two screenshots, one from Mozilla/Win98 (build from the 5th of
November) and one from Mozilla/Linux (7th November). On the linux one, you
should be able to see that there is no black line between the two white rows,
and also no line at the bottom of the yellow row.

I played with the font settings after I took the screenshot and I actually found
that setting the Text Size (in the View menu) to 150% caused the lines to
appear, so perhaps the problem is not due to linux, but just due to the
different font sizes - this might be why no-one else sees this problem. My font
settings under Linux are :

Serif: adobe-times-iso8859-1 12px
Sans-Serif: adobe-helvetica-iso8859-1
Default Type - Sans-Serif

I let the web page override the font.

Screen resolution is set to 96dpi in the preferences, but the actual X server
resolution is 75x75. I had to increase it because otherwise most text becomes
unreadable.
I can't reproduce this on Windows and it sounds like it is hard to reproduce on 
Linux. If I had a testcase, I would look at this.
Status: REOPENED → ASSIGNED
In my description of my Linux setup, I wasn't meaning to imply that you need to
set all those X server parameters etc. to see the bug - I was just trying to
give you as much information as possible. I think it's basically a reaction
between the font size and mozilla figuring out cell height.

Another thing I have noticed is that if I resize the browser window (looking at
my testcase id 18864) so that all the cells only have one line of text, the
problem disappears. But it reappears when the window shrinks and line wrapping
occurs. Does this help at all?
maybe i've found another site that shows this problem on Linux (Linux Intel
*AND* Linux PowerPC, so could it be related to GTK ?) :
it's http://www.linuxfr.org/

on that page, each article is surrounded by a 1 pixel line made with nested
tables. i don't know if it's valid html, all i know is that this trick works in
4.x but in Mozilla sometimes one thin line is missing at the bottom of a table
of two...

it's been a problem for months so i've decided to find a bug and then add this
comment. i can add some screenshot showing linuxfr.org in 4.x and Mozilla if you
want.
i've reduced the problem seen on linuxfr.org as much as i can.
my conclusion is that it's a problem involving nested tables and small font-sizes !
it's getting too weird for me, i can't tell if it's related to Simon King
screenshots or not, so i don't know if this should go in this bug report or
another one.... please tell me.

anyway, please see the attached reduced testcase...
Yes, I'm pretty sure that this is the same bug that I see. It's really annoying
because I use this "trick" a lot in my web pages to get nice-looking tables.
Just to confirm, the bug is still present in BuildID 2001012607
Actually, that's a pretty old build, isn't it? I've got two installed - a stable
one and a nightly one, but the last nightly one I got doesn't start, so sorry
about that.
QA contact update
QA Contact: chrisd → amar
i noticed that for a few days this bug has not occured anymore on linuxfr.org.
boxes are perfectly rendered.
can anyone confirm ? if so, i suggest closing this bug. 
(i'm using the more recent builds).
Yep - I confirm that it seems to be working correctly now on all my test pages.
I'm happy for it to be closed.
Looks good to me, too.
Marking fixed.
Status: ASSIGNED → RESOLVED
Closed: 19 years ago19 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.