Clicking link that opens new window changes initial window placement on restart

VERIFIED DUPLICATE of bug 210689

Status

()

Firefox
General
--
minor
VERIFIED DUPLICATE of bug 210689
15 years ago
15 years ago

People

(Reporter: dnapalm, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

When you go to a site that uses new window links, such as http://www.fark.com/,
and click on a link, then close both windows, on next startup of Firebird the
window is essentially indented. This happens even if you close the launched link
window first. This did not happen in Firebird 0.6, or any previous build I can
remember. If this isn't something fixable, is there a configuration option to
specify window placement?

Reproducible: Always

Steps to Reproduce:
1. Go to Fark.com and click on any item link, with your browser placed at the
left side of the screen and not maximized.
2. When a new window pops up, close it, and close the initial browser window as
well.
3. Open Firebird.

Actual Results:  
The initial window placement moved, slightly indented from the left side of the
screen.

Expected Results:  
It should not have moved, but retained the original placement settings, as it
would had you not opened a link in a new browser window.
(Reporter)

Comment 1

15 years ago
Further testing shows it saves the position of the last window opened for the
next startup of Firebird. This will happen with either launch links or simply
opening a new window. Opening multiple new windows will save the position of the
last window launched. Order of closing does not seem to matter, but maybe it
should. 

Either providing a way to set the placement in configuration, or saving the
position of the last window to be closed would fix this in my opinion. I know it
seems minor, but this sort of behavior is a major reason I stopped using IE.
Constantly having to move a window gets annoying.

Comment 2

15 years ago
I think this is a dupe of bug 210689.

Comment 3

15 years ago

*** This bug has been marked as a duplicate of 210689 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 4

15 years ago
verified with 20030807 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.