IE favourites are searched when "Imported IE favorites" folder has been deleted

VERIFIED WORKSFORME

Status

()

Firefox
Bookmarks & History
--
major
VERIFIED WORKSFORME
14 years ago
11 years ago

People

(Reporter: Ben, Assigned: Pierre Chanial)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

Happens always, see steps to reproduce.

Reproducible: Always

Steps to Reproduce:
1. Be connected to the Internet
2. Hit control-B
3. Type anything in the search field

Actual Results:  
Firebird HANGS after 5 seconds. I have to kill the program which closes all windows.

Expected Results:  
Not hang, but give a list of bookmarks that have the search key somewhere in the
title or URL.
WFM on current nightly.

Reporter, please try creating a new profile (run "MozillaFirebird.exe -p"
switch) and unzip firebird in a new directory, then report back. 
(Reporter)

Comment 2

14 years ago
Did extensive testing and this is what happens:

When launching Firebird with a new profile, it imports automatically the IE
favourites. I move this bookmarks to the Toolbar Folder. Up to here everything
fine. Now, the problem starts when deleting the "Imported IE favorites" folder
and restarting Firebird. From this point on two things happen:

[1] The first search in the bookmarks side bar takes very long, especially when
connected to the internet over a slow link.

[2] Firebird searches the IE favorites in addition to its own links! This
results in duplicate search results. Also, I believe that [1] is caused by [2].
I verified this by (a) removing all bookmarks from Firebird: it still found all
my bookmarks, and (b) removing all IE favorits.

This behaviour is reproducible every time on my machine with Windows 2000
professional.

In my opinion, Firebird should never search the IE favorites. Importing them
when launching it with a new profile is nice.
Summary: Bookmark sidebar search hangs when connected to the Internet → IE favourites are searched when "Imported IE favorites" folder has been deleted
(Reporter)

Comment 3

14 years ago
Maybe something was not clear: Firebird goes out to the hard disk to the
directory where your IE favourites are stored and searches them!

I noted that Firebird only does that when you remove the "Imported IE favorites"
folder from your Firebird bookmarks.
Ben, can you try this again on a current nightly?  There was a bug fixed which
involved very slow behaviour with the IE favourites on startup or search, which
should address this.

Updated

14 years ago
Blocks: 120814
(Reporter)

Comment 5

14 years ago
Confirmed. In the nightly build this problem is solved. Thank you for your help.
probably fixed by 205129, marking WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

12 years ago
Status: RESOLVED → VERIFIED
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.