have to login twice (HTTP auth)

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: augustus, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030729 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030729 Mozilla Firebird/0.6.1

When going to http://mail.myrealbox.com, or logging in throught the main page at
http://www.myrealbox.com, there are two problems when loading. Firstly, when I
enter my username and password and tell password manager to remember them, next
time I try to log in it does not auto fill it in. Secondly, even after typing my
username and password painstakingly slow to ensure I make no errors, it often
asks for it to be entered again after partially loading the page. If this
happens, whenever I go to click on something, it asks for my username and
password again, and once typed in it goes to a white page saying that my session
has timed out and that I need to log in again. Occassionally I can get in at
this stage without a problem, but more often than not I am forced to use Mozilla
or IE to check MyRealBox.

Reproducible: Sometimes

Steps to Reproduce:
1. Go to http://www.myrealbox.com or http://mail.myrealbox.com
2. Enter your username and password. If it loads correctly, log out and in until
step 3 occurs.
3. It should half load and ask for your username and password again. Nothing
will load properly now.

Actual Results:  
Nothing would load properly, session timed out.

Expected Results:  
It should have loaded properly and the session stayed logged in until I logged
out myself.

Comment 1

15 years ago
I cannot confirm the behavior with Password Manager being broken. That part is
working for me. The front page, http://www.myrealbox.com/  , is quite slow to
load, however.

I confirm the HTTP auth problem on Firebird 0.6.1 on Win XP. It is probably
already reported somewhere else, but I can't find any duplicate. The behavior of
having to login twice happens regardless of whether Password Manager is enabled.

If you go to http://mail.myrealbox.com you get an HTTP auth prompt. Even if you
enter your username and password correctly the first time, you are prompted for
them a second time.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Password manager broken, mail loading broken → have to login twice (HTTP auth)

Comment 2

15 years ago
I have getting some similar to this.
When I try to open the intranet page on my work, I'm prompted for user and pass
for each connection; i.e., first time to load the main page and one time for
each image on that page.
Username and password are stored correctly by password manager, so i have to
mantain pressed the Enter key until page loads completly.
Then the same occurs when loading any link i click into.

Updated

15 years ago
QA Contact: asa

Comment 3

15 years ago
maybe it is the same problem as my bug #227468
the first part of this bug is already reported, the second never happens for me
(and I obviously use myrealbox..)

does this still occur?
QA Contact: mconnor

Comment 5

15 years ago
This is not the same as bug 227468; that bug uses cookies.

However, I too am seeing this behaviour. Logging into my private webmail
service, that uses HTTP authentication over SSL, I am presented with the
authentication dialog for every resource -- every image, frame, etc. Password
manager correctly stores the passwords, so that it is only necessary to click
"OK", but the dialog is nonetheless displayed.

Without password manager (e.g., not checking the "remember this" box), the
dialog is also presented for every resource, but is empty and must be manually
completed.

This is a major usability issue for me. It did not appear prior to FireFox 0.8.

Comment 6

15 years ago
I have an issue similiar to this but a little different.  My company has
firewalls that require authentication before being permitted to pass through to
the real machine.  The authentication can happen via three protocols, ftp,
telnet, and http.  If I try to get to a webconsole of our netscreen firewall
which is located behind another firewall which is doing authentication, my web
request gets challenges by the first firewall, I give it my credentials and I am
allowed to pass.  Still in the same browser window, another login box appears,
this time its the real webserver that I was attempting to access.  When I give
it the correct credentials to log in I get an error.  This happens to be a
netscreen firewall and the error is " This WEB access has been denied due to
user name/password change."  This is not an issue in IE and with firebird or
firefox I have to close all the browser windows and open it up again. 

It appears that the login caches the info but on the second authentication uses
the first login as well as the second one.  

Comment 7

15 years ago
Rob,     (In reply to comment #6)

I think your problem is not the same as this bug. You may be experiencing bug
230190, however.

Comment 8

15 years ago
There is an HTTP authentication testcase at http://jigsaw.w3.org/HTTP/Basic/ --
but I do not see this bug using that page.

Login is guest/guest.

Comment 9

14 years ago
Ehmm... i think this bug was fixed at last in 0.8. (maybe 0.8.1? i don't remember).
Maybe it was a profile bug, and for me it's solved because Firefox stores data
in a new location?

Anyone can confirm:
Fresh install: OK
Install over previous version (< 0.8)*: Bug appears

(*) I install 0.9.1 over 8.x and everything is OK

[I'm trying to close this old bug report]
as originally reported, this is WORKSFORME

some of the auxilliary/strange cases should be tested in Mozilla as well and
reported in Browser -> HTTP: Networking
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.