White is used as color in charts

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
15 years ago
6 years ago

People

(Reporter: draichle, Assigned: gerv)

Tracking

2.17.4
x86
Windows 2000

Details

(Reporter)

Description

15 years ago
At our bug-charts white is used as color for the first dataset. I looked at the
code but I didn't found where the color is chosen. Are there any standard colors
of the charting module?

We have installed:
GD v2.07
Chart::Base v2.2
GD::Graph v1.43
GD::Text::Align v1.18
Daniel: could you be a little more specific? Bugzilla has several sorts of bug
chart. Are you talking about the very new generic plot-anything charts
introduced since 2.17.4, the very old ones (NEW/REOPENED etc.) or something else?

Gerv
(Reporter)

Comment 2

15 years ago
I am talking about the very old ones.
I've never seen this problem. However, the colours are chosen on line 326 of
reports.cgi in the current codebase (grep for "colors" in other codebases). I
would guess that you could add an entry to that hash like:

dataset0 => [0, 0, 0], # black

to turn the first dataset's line (for example) black.

Gerv

I can't reproduce this. If anyone else does, I'll look into it further.

Gerv
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.