remove "Use Default" (broken anyway) from Bookmarks Manager - Move; dialog has no title; increase the default size of the dialog

RESOLVED FIXED in Firefox1.5

Status

()

Firefox
Bookmarks & History
P5
normal
RESOLVED FIXED
15 years ago
12 years ago

People

(Reporter: Pham, Assigned: Gavin)

Tracking

Trunk
Firefox1.5
Points:
---
Dependency tree / graph
Bug Flags:
blocking-aviary1.5 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [asaP1])

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

15 years ago
willerg tolde me to do a new bug so here it is
(Reporter)

Comment 1

15 years ago
And window is very small, so kind of useless. Maybe it shouldn't even be there
when you have drag/drop

Comment 2

15 years ago
Name's Wilberg. But call me Steffen.

The "Use Default" button was removed from Mozilla so I guess it's obsolete. It
takes you to the root folder as far as I can see.
The "New Folder" button doesn't even work (it does in Mozilla). But I think it
should be fixed instead of removed.
The box is too small, but you can enlarge it and it remembers that. It should be
larger from the beginning though.
Summary: get rid of redundant "new Folder" "Use Default" from "Move → get rid of "New Folder" and "Use Default" from Bookmarks Manager - Move
(Reporter)

Comment 3

15 years ago
Just like bug 214527 wants to make the window not so small, while this one is
fixed, it could also be made the window bigger.

But again, why another window for move when you can drag/drop?

Comment 4

15 years ago
> But again, why another window for move when you can drag/drop?
You can't drag and drop with your keyboard. You can hit Alt-M though.
Removing the "use default folder" is a no brainer, since the function it calls
isn't even defined anymore. For "New Folder", I'm not sure why you would want to
remove it. I agree with Steffen that it should be fixed and I'll look into doing
that.
Assignee: p_ch → gavin.sharp
Severity: enhancement → normal
Priority: -- → P5
Target Milestone: --- → Firefox1.1
Version: unspecified → Trunk

Comment 6

14 years ago
The Move dialog has no title in trunk builds. "New Folder" works fine in 1.0 and
trunk. Resummarizing.
Summary: get rid of "New Folder" and "Use Default" from Bookmarks Manager - Move → remove "Use Default" (broken anyway) from Bookmarks Manager - Move; dialog has no title; increase the default size of the dialog
Created attachment 174111 [details] [diff] [review]
Patch v1

Removes the unused button, fixes the dialog's title, and increases the
tree-view's height slightly.
Attachment #174111 - Flags: review?(mconnor)
Whiteboard: [patch-r?]
Attachment #174111 - Flags: review?(mconnor) → review?(vladimir)
Status: NEW → ASSIGNED
Flags: blocking-aviary1.1?
Created attachment 178163 [details] [diff] [review]
Unbitrotted
Attachment #174111 - Attachment is obsolete: true
Attachment #178163 - Flags: review?(mconnor)
Attachment #174111 - Flags: review?(vladimir)
Attachment #178163 - Flags: review?(mconnor) → review?(vladimir)

Updated

13 years ago
Whiteboard: [patch-r?] → [patch-r?] [asaP1]
*** Bug 290370 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Flags: blocking-aviary1.1? → blocking-aviary1.1+
Attachment #178163 - Attachment is obsolete: true
Attachment #178163 - Flags: review?(vladimir)
Created attachment 186435 [details] [diff] [review]
Updated, fix window persisting
Attachment #186435 - Flags: review?(mconnor)

Updated

13 years ago
Attachment #186435 - Flags: review?(mconnor) → review+
Attachment #186435 - Flags: approval-aviary1.1a2?
Whiteboard: [patch-r?] [asaP1] → [asaP1][checkin needed]

Updated

13 years ago
Attachment #186435 - Flags: approval-aviary1.1a2? → approval-aviary1.1a2+
Whiteboard: [asaP1][checkin needed] → [asaP1][checkin needed][a+]
checked in
Whiteboard: [asaP1][checkin needed][a+] → [asaP1][a+]
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Whiteboard: [asaP1][a+] → [asaP1]
Depends on: 300988
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.