No default throbber in OS X

RESOLVED FIXED in Firefox1.5

Status

()

Firefox
Toolbars and Customization
RESOLVED FIXED
15 years ago
11 years ago

People

(Reporter: David Nedrow, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({fixed-aviary1.0})

unspecified
Firefox1.5
PowerPC
Mac OS X
fixed-aviary1.0
Points:
---
Dependency tree / graph
Bug Flags:
blocking-aviary1.0mac +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

Under OS X, there is no throbber in Firebird 0.6 and 0.6.1. This means there is
no way to know if a page is still loading or you've simply gotten a blank page
(it happens).

I suspect the throbber isn't enabled by default because in the Windows version
it's now part of the menubar, not the toolbar.

Regardless of where it is in Windows, it only makes sense for it to be part of
the toolbar under OS X and it should be enabled by default.

I admit that I did find another bug report very similar to this, but it had
turned into a bit of a row. That report is 213896. Fell free to close this as a
dupe if necessary, but it would be nice to deal with the issue at hand without
getting into pointless arguments.

Reproducible: Always

Steps to Reproduce:
1. Launch Mozilla
2.
3.



Expected Results:  
The throbber should be part of the toolbar under OS X and should be enabled by
default.

Comment 1

15 years ago
I'm going to confirm... but mark dependant on the decision made in bug 213896.
based on the call made there this may be a dupe or it may require a mac specific
patch.

Also note, at one point the throbber was on its own toolbar, presumably the
menubar.. see bug 210563

(to be honest tho, 6 comments in a bug is hardly grounds for worrying about a
bug getting lost under useless comments)

Status: UNCONFIRMED → NEW
Depends on: 213896
Ever confirmed: true

Updated

14 years ago
Depends on: 227099
This bug has been fixed with the new default theme for OS X

Comment 3

14 years ago
In which version of the browser does the throbber appear? I know that
customization allows for an "activity indicator", but it's not on by default.

(In reply to comment #3)
> In which version of the browser does the throbber appear? I know that
> customization allows for an "activity indicator", but it's not on by default.
> 
> 

that's right, it's not included in th default set

Comment 5

14 years ago
Requesting blocking 1.0

The throbber exists for OS X. It's just not included on the toolbar by default
(unlike other platforms).

This bug could probably be resolved with very little effort. Either:
-it really shouldn't be on by default (although I see no reason for this and
hope that it's not intentional). In which case this bug could be closed right
now as WONTFIX.
or
- it should be placed on the toolbar by default
Assignee: hyatt → bugs
Flags: blocking1.0?
Flags: blocking1.0? → blocking1.0+

Updated

14 years ago
Flags: blocking1.0+ → blocking1.0mac+

Comment 6

14 years ago
There is no need for an activity indicator in the toolbar since activity is
already indicated by a progress bar in the status bar. The status bar is the
correct place for status information.
(In reply to comment #6)
> There is no need for an activity indicator in the toolbar since activity is
> already indicated by a progress bar in the status bar. The status bar is the
> correct place for status information.

As long as the throbber exists in other platforms (in aditon to the statusbar
info) Activity indicator should be included in the default MacFirefox toolbar.
WFM in last AVIARY nightlies.

New profile cotaing the Activity Indicator.
The throbber is displaying by default in 0.9.1. Marking as FIXED.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 10

14 years ago
Reopening.

I can't comment on the 0.9.1 branch build, but it's definitely not fixed on the
trunk (latest nightly: 20040706 Firefox/0.8.0+).

I trashed all preferences, started it up, and the throbber was still missing.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
I have to agree with Asaf and Steven: this is working properly in latest Aviary
builds.
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago13 years ago
Resolution: --- → WORKSFORME

Comment 12

13 years ago
Deja vu? Reopening. As I said in comment 10, this isn't fixed on the trunk.
Whether it's fixed on the branch or not should be irrelevant to the bug status
if it's not fixed on the trunk as well.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 13

13 years ago
moving blocking1.0mac bugs to Firefox1.1 Target Milestone.
Target Milestone: --- → Firefox1.1
The branch code has been coppied over to the trunk
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED

Updated

11 years ago
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.