paste long text in a form is too slow

RESOLVED INVALID

Status

()

RESOLVED INVALID
15 years ago
12 years ago

People

(Reporter: xspuente, Unassigned)

Tracking

({perf})

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ast-ES; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ast-ES; rv:1.4) Gecko/20030624

When pasting long text (500,000 letters) in a form, Mozilla is too slow in
comparisson to other programs or browsers. It takes a couple of seconds, instead
of being inmediate or only 1 second. It has been reproducible from all major
releases till now.

Reproducible: Always

Steps to Reproduce:
1. Go to
http://genome.ucsc.edu/cgi-bin/hgc?hgsid=23574695&g=htcGetDna2&table=&o=1457976&l=1457976&r=1492610&getDnaPos=chr2%3A2000000-2500000&db=rn3&hgSeq.cdsExon=1&hgSeq.padding5=0&hgSeq.padding3=0&hgSeq.casing=upper&boolshad.hgSeq.maskRepeats=1&hgSeq.repMasking=lower&boolshad.hgSeq.revComp=1&submit=Get+DNA,
select all and copy.
2. Go to http://www.ncbi.nlm.nih.gov/blast/bl2seq/bl2.html, and paste in any of
the forms (called Sequence 1 or Sequence 2) 


Actual Results:  
It takes 16 secs

Expected Results:  
Take 1 sec or less, as in IE or any text editor.

There is a dependency on the text lenght, as it increases size it takes longer
to load. It might be the same in other browsers, but as it takes less than 1
sec, you don't feel the difference.

Updated

15 years ago
Keywords: perf

Comment 1

15 years ago
I too have experienced some inefficiency with Mozilla form handling.  I frequent
www.dapcentral.org where there are large form lists for video inventories (some
with a few hundred radio buttons).  While IE will submit even a large form such
as this almost instantly, Mozilla hangs momentarily while processing all the
data.  Not exactly priority one, but I agree it would be wise to have someone
look into making it more efficient.

Comment 2

15 years ago
Confirming on 2003080304 WinXP.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

15 years ago
I'm seeing this in Linux with 1.7rc1, but it was OK before. This seems to be
true when pasting anything, anywhere. It's now really slow. The bug seems to
happen most, but not all times when pasting.

Richard

Comment 4

12 years ago
reporter's URLs no longer valid so marking bug -> INVALID
If this is still a problem on a current version please list steps to recreate.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.