Closed Bug 214943 Opened 18 years ago Closed 18 years ago

wrong nodeType

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 26179

People

(Reporter: keepitcool4, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030718
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030718

I really don't know what the problem is.. but IE and Opera seem to handle the
file (the given URL) correct and the output, if you'd interpretate (sorry
probably bad english) -yourself, it should be 1. 

thisDom.childNodes[1].nodeType

(should)point to the body which has a int value of 1-nodeType instead.. it gives 3

Reproducible: Didn't try

Steps to Reproduce:
1.
2.
3.



Expected Results:  
see details

bug appears in all known versions.. the ones I tried were
1.3
1.4
1.5 ALPHA
URL is unreachable.  Please attach the testcase using the
"Create a New Attachment" link on this bug.  Thanks.
type == 3 is a text node.  See bug 26179 for some lengthy discussion on the matter.

*** This bug has been marked as a duplicate of 26179 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
OS: Windows 2000 → All
Hardware: PC → All
Resolution: --- → DUPLICATE
Component: DOM: Core → DOM: Core & HTML
QA Contact: ian → general
You need to log in before you can comment on or make changes to this bug.