Drop arrows overlap text buttons in text-only Modern skin

RESOLVED WORKSFORME

Status

SeaMonkey
UI Design
--
trivial
RESOLVED WORKSFORME
15 years ago
5 years ago

People

(Reporter: Stephen Mercer, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030624

This bug affects the browser, mail and composer. Some buttons in the button bar
(such as Back, Forward, Get Msgs, or Print) have drop arrows next to them. In
the Modern skin with the text only view of buttons, these drop arrows overlap
the text. The "Get Msgs" button in Mail has the "s" completely obscured.

Reproducible: Always

Steps to Reproduce:
1. With all other out-of-the-box configurations the same, configure preferences
to the Modern skin and Text Only buttons.
2. Restart Mozilla
3. Examine the button bar
Actual Results:  
The drop arrows are in the wrong place relative to the text on the button.

Expected Results:  
reserved more space for the button as a whole and move the drop arrow more to
the right. Perhaps something is wrong with the font size calculations?
(Reporter)

Comment 1

15 years ago
I tried to attach an image of the bug, but the attachment system kept telling me
I had not specified a file to attach, no matter how many times I browsed or
typed the file name in. Perhaps this is another bug? I even tried with
javascript and cookies fully enabled.

Comment 2

15 years ago
*** Bug 214961 has been marked as a duplicate of this bug. ***

Comment 3

15 years ago
Happens also on Linux.
OS: Windows 98 → All

Comment 4

15 years ago
Created attachment 129138 [details]
1024x768 screenshot W2K, W98, OS/2 & Linux compared

Fixing this will probably depend on any of several menu text size bugs, such as
bug 206482 or bug 207593.

Comment 5

15 years ago
Confirming on 2003080304 WinXP.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Product: Core → Mozilla Application Suite
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a3pre) Gecko/20070222 SeaMonkey/1.5a] (nightly) (W2Ksp4)

Bug still there:
on MailNews /W2K, "Get Msgs" is "fine", but (disabled) "Forward" is not !
Summary: Drop arrows overlap text buttons in Win98-text only view Modern skin → Drop arrows overlap text buttons in text-only Modern skin
Assignee: bross2 → guifeatures
QA Contact: pawyskoczka
Filter "spam" on "guifeatures-nobody-20080610".
Assignee: guifeatures → nobody
QA Contact: guifeatures

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design

Comment 8

5 years ago
WORKSFORME. I fixed this when implementing customizable toolbars.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.