URL causes instant crash.

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
critical
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: Pierre Beyssac, Unassigned)

Tracking

({crash})

Trunk
x86
FreeBSD
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.5a) Gecko/20030802
Build Identifier: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.5a) Gecko/20030802

The above URL causes an instant crash of the browser: "Bus Error".
Note that the home page of the same site works.

Reproducible: Always

Steps to Reproduce:
1. just go the URL


Actual Results:  
Mozilla crashed.

Expected Results:  
:-)

It must be a recent bug, because Mozilla 1.4 worked on the same
page.

Comment 1

15 years ago
WFM 2003080103/OS X

Report, do you have a talkback id or crash logs with more iformation on the crash?
Severity: normal → critical
Keywords: crash

Comment 2

15 years ago
WFM: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030728
Mozilla Firebird/0.6.1
(Reporter)

Comment 3

15 years ago
After skimming through the HTML/Javascript code, it appears that
it is the Shockwave/Flash plugin (npflash.so) which causes the
crash. It didn't crash in Mozilla 1.4 (it didn't work either, but
I left the plugin anyway) and I didn't recompile it since then;
maybe that's an ABI problem.

I removed the plugin it and it fixes the crash.

Most probably my plugin is broken and you can close the bug report,
but here's a skimmed-down version of the page that exhibits the
problem in case you want to test with a known-good plugin.

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<HTML>
<HEAD>
</HEAD>
<BODY>
<embed
src="http://sbx.pagesjaunes.fr/RealMedia/ads/Creatives/autopromo3-1_468/ban_quidonc_nom.swf?clickTAG=http://sbx.pagesjaunes.fr/RealMedia/ads/click_lx.ads/www.pagesjaunes.fr/GENERAL/GENERAL/PB/753196596/Top/autopromo3-1_468/ban_quidonc_nom.html/47422d364330464335392d3344464334?"
pluginspage="http://www.macromedia.com/shockwave"
type="application/x-shockwave-flash">
</embed>
</BODY>
</HTML>

Comment 4

15 years ago
Created attachment 130541 [details]
testcase from comment #3

Comment 5

15 years ago
Marking WFM regarding last reporter's comment.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.