resource-hungry threads result in UI becoming unresponsive and corrupt

RESOLVED DUPLICATE of bug 204374

Status

defect
RESOLVED DUPLICATE of bug 204374
16 years ago
15 years ago

People

(Reporter: bugspray, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030718
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030718

If I open a forum thread with a lot of images the UI will eventually become
unresponsive when loading the page.  When using tabbed browsing, it can still
scroll through the tabs but the web page section and tabs all freeze/corrupt.  I
may get small animations or icons showing through when I scroll and the twirling
anim next to tabs still loading still displays but the browser is unusable until
I re-open it.  Seems to use a fair bit of RAM when this happens so it seems like
a resource issue.  IE (sorry to use language like that in here) will display the
page with much less hassle and never has any problems.


Reproducible: Always

Steps to Reproduce:
1. Probably the hotties section in off-topic is the most reliable place to start
2. Do not follow these instructions if you're at work, or have moral objection
to seeing pictures of beautiful women
3. Open a thread with a large number if images in it
4. Keep your pants on, you're investigating a bug here!
Actual Results:  
browser UI becomes unresponsive

Expected Results:  
worked :)

Apologies for the non-worksafe page (and off-topic is down more often than not
atm) - I have had this problem with other pages too but I can't recall any. 
Problem has existed through several moz revisions (but have been too lazy to
report it)

If there aren't any threads large enough open several using tabbed browsing. 
Non-broadband bug testers need not apply :)

Comment 1

16 years ago
see bug 204374 comment 147

*** This bug has been marked as a duplicate of 204374 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.